AppCode and C++1y/C++14

Answered

Any support for C++1y/C++14 in the making? It does compile, e.g. trying to implement a generic lambda, but there is no support for code completion, and the IDE marks the code as faulty at the moment.

5 comments

Hi Jennifer,

Yes, we're working on better support of C++11/14 at the moment. We plan to ship extended support of C++ in the next major release of AppCode.

Best Regards,
Alexey

0

Cool Alexey, thanx! Any chance you will reveal the estimate for the next major release? ;-)

0

Jennifer, we're planning to ship early preview of the release before the summer.

Best Regards,
Alexey

0

Hello, I'm seeing errors when creating lambdas and also when importing other library classes employing lambdas. Should AppCode be supporting C++11 lambdas at the moment? Tested with both 2017.1 and 2016.3.2

0

Hi Adam.

It would be great if you send us some self-sufficient code snippets where you see such issues.

AppCode shares C++ support code base with CLion, so you might want to take a look at CLion tracker (to see if there are some similar lambda-related issues) or just file an issue there (providing some examples). 

0

Please sign in to leave a comment.