Emmet not expanding e.g. p5

Hi,

I hope this is the right place to post my question!

Due to a new setup I am confronted with the situation to configure each and everything again to my needs, among such thing the phpStrom 7.1.3 IDE (on a Mac). And I hope you have a hint for me!

i remember that it was possible to type something like "p5" into a css file, which then expanded to "padding: 5px;". But that doesn't work anymore.
Does anybody of you know whether I have to adjust a specific configuration somewhere? Or is a special plugin needed to bring bacl that functionality again?

Thanks for your feedback in advance!

Best regards,
Robert

8 comments
Comment actions Permalink

Hi there,

It still works for me (p5 in css file).

All Emmet settings are located in "Preferences | Emmet" -- it's bundled so no extra plugin is required.

0
Comment actions Permalink

Thanks for your quick response!

Strangely enough it does not work in my IDE. Could the be any chance that another Plugin overrides Emmet's functionality???

hmmm...

I am grateful for any brainstorming help...

Thanks again!

Robert

0
Comment actions Permalink

Screenshots of your Emmet settings (and other relevant things, if any), please.

You may disable all 3rd party (non-bundled) plugins if you think that some of them may interfere (and check how it will behave).

0
Comment actions Permalink

Thanks again for your response, Andriy!

Enclosed 2 screenshots, don't know if they help... any ideas?

Thanks!
Robert

PS: i added a 3rd screenshot showing a css "in action". I also (de)activated Zen CSS in Live Templates - no difference...



Attachment(s):
phpstorm-plugins.jpg
phpstorm-Emmet-settings.png
phpstorm-css.png
0
Comment actions Permalink

Still no real ideas -- settings look good.

1) Have you restarted IDE after disabling plugins?

2) What actions do you have mapped to Tab key ("Pref | Keymap" -- use "Search by key" button -- the one after search field) ?

3) Anything interesting in idea.log (Help | Show log in...) ?

4) Do you have "Autopopup code completion" enabled (Pref | Editor | Code Completion)? If so -- what do you see after you type "p5" (before you press Tab)?

5) Was it actually working on this machine before? If so -- have you tried "File | Invalidate caches and restart..."?

6) Try disabling "CSS Emmet", exit Preferences saving them, then re-enable again.

7) You can always try v8 EAP build (can be run in parallel).

8) If still nothing -- try starting from scratch (backup and delete IDE-wide settings and see if this will do any good) -- https://intellij-support.jetbrains.com/entries/23358108-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs

0
Comment actions Permalink

One more thing to check (in addition to options listed by Andriy): Settings/Live templates/Zen CSS - are they enabled?

0
Comment actions Permalink

Thanks for your help, you guys!!!! Very kind of you!

I tried everything you suggested, but finally I chose the way to go with EAP. Here it works fine.
Will I be able to update EAP to a full Version? Or will I have to reinstall another version and therefore lose my settings again? Or can I use and export-settings-file from EAP in the final version?

Thank you very much!

Have a good evening!
Robert

0
Comment actions Permalink
Will I be able to update EAP to a full Version?

Yes (uninstall EAP and install final instead).

NOTE: license for EAP build only lasts 30 days -- after that it will stop working. If you want to continue using EAP build, you will need to install and use newer EAP build (new build is released every 1-2 weeks).

Or will I have to reinstall another version and therefore lose my settings again?

It's unlikely that v8 final will be released before current EAP will expire. So you will have to install another few EAPs before v8 final.

Your settings are preserved between installations.

Or can I use and export-settings-file from EAP in the final version?

No need -- final build uses the same settings as EAP one (settings for v8 are stored in the same folder for all v8 builds (final or EAP) and do not intersect with previous (e.g. v7.x) versions hence different versions can be run alongside).

But yes -- you can use "File | Export Settings..." and then "File | Import Settings.." between v7 and v8 (or whatever) at any time.

0

Please sign in to leave a comment.