Deployment exclude wildcards not working?

I'm trying to speed up "Sync with Deployed" operations by setting up exclusions for certain large server file types by their extensions, and I can't get it to work.

Specifically, I'm setting paths in Tools | Deployment | Configuration | {My Server} | Excluded Paths. I've added several "deployment path" exclusions, and then used the "Sync with deployed" command on a directory in my project. I'm getting the following results:

  • Explicit paths like "/var/www/path/bigFile.bin" work fine, and those files on the server do not appear in the Diff results window.
  • Just specifying an extension, like ".bin" does not work; the server files still appear in the results.
  • Adding a wildcard to the above and using "*.bin" also does not work.
  • Wildcards in general do not appear to work either: for instance, "*bigFile*" does not prevent bigFile.bin from appearing in the results.


Have I missed something fundamental about how this feature is intended to work? All the documentation I can find states that wildcards should be supported. Am I using the wrong character? I tried substituting '%' for '*', thinking it might follow SQL LIKE syntax, but that hasn't changed the results.

2 comments
Comment actions Permalink

Hi there,

Have I missed something fundamental about how this feature is intended to work?

Yes .. most likely.

All the documentation I can find states that wildcards should be supported.

Any links for that documentation?

Am I using the wrong character? I tried substituting '%' for '*', thinking it might follow SQL LIKE syntax, but that hasn't changed the results.

Nope -- if anything, the * should work and not %

  • Just specifying an extension, like ".bin" does not work; the server files still appear in the results.
  • Adding a wildcard to the above and using "*.bin" also does not work.
  • Wildcards in general do not appear to work either: for instance, "*bigFile*" does not prevent bigFile.bin from appearing in the results.

This not supposed to work in "Excluded paths" tab as it does NOT accept patterns. Please provide the link for official documentation where it states that it should.


In any case: Please show screeshots. Right now (based on this limited info you have provided here) it sounds like you are doing wrong thing -- applying certain things in the wrong place.

0
Comment actions Permalink

Aha, I see. I had misread the documentation here. I was trying to add the exclusions on a per-server basis under Tools | Deployment | Configuration | {My Server} | Excluded Paths, but as you say, it seems that wildcards are only supported in the more general deployment options in Tools | Deployment | Options. I added my patterns to the "Exclude items by name" box there and it seems to be working now.

1

Please sign in to leave a comment.