macro: keyboad shortcut does not work

I've made a keyboad short cut for macro (Alt+L - no conficts) - macro is some typing

When I run it using menu Tools everything works fine.

I press Alt+L and I've got menu View opened - very funy!!!

I also have got my macro typed but I does not save the situation. The focurs of cursor is moved from editor to menu. Crazy.

I've tried other key combinations with macros - IDE works like crazy. Doing something that is not expected. And some times macros just stops to be avaliable from Tools menu (gray color) - only program restart.

WebStorm 2.1 on windows 7 x64

4 comments

Hello Alex,

'Alt +<Letter>' shortcuts are reserved for mnemonics:
mnemonic.png

You can change the shortcut or disable mnemonics in menu (see IDE Settings | Appearance | Disable mnemonics in menu).

Thank you for feedback!

0

I've disabled mnemonics. It still works the same way - opens some menus and after disables (colors in grey) all macros in Tools menu - so they become not avaliable.

0

Alex,

No ideas. Please submit an issue -youtrack.jetbrains.net/issues/WI#newissue=yes

Thank you for feedback!

0

I am also having problems.

I am using a MAC and have assigned a shortcut via keymap (control-shift-return).

The macro runs fine from the menu, but the shortcut results in only the first step of the macro running, then it stops.

A.

0

Please sign in to leave a comment.