Unused imports never go away when using "Optimize imports on the fly"

I checked this option "Optimize imports on the fly" (under
Settings/Editor) but when I have unused imports, they never disappear. I
have to explicitly call Optimize Imports.
Is this normal?

Thanks,

BoD

4 comments
Comment actions Permalink

In Java files this should work. I think automatic optimization is currently disbled in JSPs for one reason or another.

BoD wrote:

I checked this option "Optimize imports on the fly" (under
Settings/Editor) but when I have unused imports, they never disappear. I
have to explicitly call Optimize Imports.
Is this normal?

Thanks,

BoD

0
Comment actions Permalink

I'm sorry it does not work.

BoD

Stephen Kelvin wrote:

In Java files this should work. I think automatic optimization is
currently disbled in JSPs for one reason or another.

BoD wrote:

>> I checked this option "Optimize imports on the fly" (under
>> Settings/Editor) but when I have unused imports, they never disappear.
>> I have to explicitly call Optimize Imports.
>> Is this normal?
>>
>> Thanks,
>>
>> BoD

0
Comment actions Permalink

It works for me. Once I start typing in a java source file that has
unneeded imports, they are removed.

On Thu, 11 Aug 2005 10:57:04 -0600, BoD <BoD@JRAF.org> wrote:

I'm sorry it does not work.

>

BoD

>

Stephen Kelvin wrote:

>> In Java files this should work. I think automatic optimization is
>> currently disbled in JSPs for one reason or another.
>> BoD wrote:
>>
>>> I checked this option "Optimize imports on the fly" (under
>>> Settings/Editor) but when I have unused imports, they never disappear.
>>> I have to explicitly call Optimize Imports.
>>> Is this normal?
>>>
>>> Thanks,
>>>
>>> BoD

0
Comment actions Permalink

It doesn't work with my current project, they stay here.
I'll try to make a new project to see if I can reproduce the behaviour.

BoD

John Zittlau wrote:

It works for me. Once I start typing in a java source file that has
unneeded imports, they are removed.

On Thu, 11 Aug 2005 10:57:04 -0600, BoD <BoD@JRAF.org> wrote:

>> I'm sorry it does not work.
>>
>> BoD
>>
>> Stephen Kelvin wrote:
>>
>>> In Java files this should work. I think automatic optimization is
>>> currently disbled in JSPs for one reason or another.
>>> BoD wrote:
>>>
>>>> I checked this option "Optimize imports on the fly" (under
>>>> Settings/Editor) but when I have unused imports, they never
>>>> disappear. I have to explicitly call Optimize Imports.
>>>> Is this normal?
>>>>
>>>> Thanks,
>>>>
>>>> BoD


0

Please sign in to leave a comment.