Spelling in other languages


I have got a lot of german content and phpStorm draw a because of this many of green rippled lines in the translation files. So I looked for a spelling setup with different language and found the plugin Spellchecker and Spellchecker German Dictionary. I installed both, but the green lines stayed.
Second try with Preferences>Project Settings>Spelling was better. I downloaded the file neu_de.dic from http://www.winedt.org/Dict/. Set the path for Custom Dictionairies and most of the green ripplet lines disappeared. But there are still many of them, always under words with german umlauts [äöüß].
I think phpStorm get the file in the wrong format.
I tried to save the file in different style [latin1|utf-8|mac_] but the green lines are still there.

So there are two questions left:
1. For what are the plugins Spellchecker and Spellchecker German Dictionary because they have no impact on the Spellingbehavior in phpStorm? (Should I deinstall both, if I like spellChecking in File with phpStorm in German?)
2. How can I solve the problem with the umlauts?

Maybe it's important to know the system facts: ( I think os x's mac_roman throw a spanner in the works of phpStorm...)
mac OS X Lion
phpStorm 3.0

Best regards


Hi Martin,

No additional spellchecking plugin is required -- it works fine for me without it (I'm on Windows 7 x64). Here is what I have done:

  1. Downloaded German (new sp) dictionary from that website
  2. Extracted de_neu.dic file from zip archive and opened in Notepad++
  3. Removed copyright comments
  4. Converted from ANSI (or whatever encoding it was) to UTF-8 without BOM
  5. Converted line ending from UNIX to Windows format (not sure if this is required)
  6. Saved it somewhere in a separate folder (so only dictionary files are there)
  7. In PhpStorm: Settings | Spelling | Dictionaries --> used "Add" button to add that folder
  8. Make sure that file will have a tick next to the dictionary file

I then tested this in UTF-8 encoded PHP file -- no spellchecking marks visible:

$test = "Say süss";


Hello Andriy

You are right. Thank you for your accurately description. Bizarrely I did the same before I wrote the first entry in this matter. With different tools, but almost similar.
I did it again, with virginally unzipped file and with other tools - with the same result.
But after a restart from phpStorm, all was OK.

I changed to "my old file" and did also a restart. And the green lines were disappear....

So again, you gave me the solution, although this time, it was only the confirmation, there have to be something else.
I uninstall the two plugins - even though I don't know yet, for what they are- and all is working fine.

Thank yoy again!

All the best


Hello, I followed the procedure by downloading the zip en http://www.winedt.org/Dict/ 
on the UNICODE version but if I install it in phpstorm it does nothing?
Did I forget something?


Hi aurelien,

Did I forget something?
Quite possible. I have followed my own instructions (1ts reply here) and it worked fine.


Check PHPDoc instead of string constants - bug's still there. Spellchecking breaks on words containing non-ASCII characters, although both dictionary and editor file are UTF-8 encoded, both without BOM. I've already tried changing new-line sequences from Unix to Windows, but to now avail.
Screenshots for polish example attached. Note that in ordinary block comment (/* ... */) this works as well - the only problem is PHPDoc (/** ... */).


gtraxx a écrit:

Hello, I followed the procedure by downloading the zip en http://www.winedt.org/Dict/ 
on the UNICODE version but if I install it in phpstorm it does nothing?
Did I forget something?

I had similar issue. I restarted PhpStorm and it seems to work now.


So, here is what to do with the dictionary from http://winedt.org/Dict/ to be used within WebStorm on Mac OS X:

  1. Download the UNICODE version fo the file
  2. Remove the header (just to be sure, because I don't know if it is intepreted as content otherwise)
  3. Convert it from unicode-16 to utf-8 with iconv, e. g.:
    $ iconv -f UTF-16 -t UTF-8 de_neu.dic > de_neu.utf-8.dic
  4. Move the converted file back to its original name (or remove the original, just to avoid confusion).
  5. Restart WebStorm



Please sign in to leave a comment.