How to show image preview on autocomplete

Hi, please tell me how to preview image on autocomplete when <img src="[cursor is here]">.
I already tried to check "IDE Settings > Editor > Code Completion > Autopopup documentation in (ms)".
This setting popups "Documentation for (image)" but, it shows a text "PsiBinaryFile:(filename)" only, no image.
Same results on all other images. Is there any additional settings required?
I need only image preview. File documentation is not necessary. (ex: popups on PHP: require("[cursor is here]"));popup.png
Thanks

9 comments
Comment actions Permalink

Hi there,

Manual invocation of "View | Quick Documentation" Ctrl+Q works for me

screen01.png

P.S.
Since I do not use automatic code completion popup (as it often pops up at unwanted for me moments) I cannot tell if it will work differently there .. or why it worked like that in your case.

0
Comment actions Permalink

Thanks, In my case, Ctrl+Q(Manual Popup) ends up with the same results.
But I found that happens on PHP file only. It works correct on HTML file.
Does anyone know the way to make image preview available on PHP mode?

0
Comment actions Permalink

Does anyone know the way to make image preview available on PHP mode?

As you can see from my screenshot it was PHP file (php instructions are visible on couple of lines).

Or you are talking about something different? If so -- please show a screenshot that would show all details.

0
Comment actions Permalink

Opps, I didn't see your screenshot carefully. I am talking about the same topic as you said.
This screenshot, it is only change file extention .php => .html on the same content. It works.
But why? In my case it doesn't works on PHP file. I wonder there is a cause in my settings.
rapture.png

0
Comment actions Permalink

No clue.

What is your PhpStorm version?

0
Comment actions Permalink

Thanks, the version is PhpStorm 7.1.3 Build #PS-133.982.  

0
Comment actions Permalink

I did mine in v8.

Please try v8 EAP build (can be run alongisde to v7: IDE settings are stored separately; just backup project settings (.idea subfolder) if you plan go back to v7 as some project settings may be lost when going back)

PhpStorm EAP

0
Comment actions Permalink

On v8 EAP, it works correctly!
I didn't notice EAP because my update setting is set for major release.
It is solved. Thank you very much for your answer.

0
Comment actions Permalink

Hold Shift and hover the mouse over the link

0

Please sign in to leave a comment.