monitoring keyword todo

sometimes i have properties called "todo":

<?php

/**
* @property mixed mode
* @property mixed todo
*/
class params { .... }


phpstorm always parses this as a real todo comment, does anyone know howto fix that ?

//todo .... <--- A REAL TODO
@property mixed todo <--- NO REAL TODO

thanks,
micha

4 comments
Comment actions Permalink

Hi there,

"Settings | TODO" -- you can alter todo matching patterns there

0
Comment actions Permalink

thanks,

\/\/todo\b.*


did the job for me...

0
Comment actions Permalink

Just a note: this pattern will not match // todo or @todo

If it's about your code only.. then it does not matter. But if it should cover somebody else's code as well ... then you may want to improve the pattern a bit :)

0
Comment actions Permalink

thanks for explaining a very simple regex  ;)

0

Please sign in to leave a comment.