External Javadoc

Hi,

I have a somewhat stupid problem and according to Google and the KB I'm
the only one...

I'd like to use "External Javadoc" (aka Shift-F1) but when I press it on
classes/methods that are not from my project, I get a "The
documentation for this element is not found.\nPlease add all the needed
paths to API docs in Project Settings.".

Well, there is no "API docs" in "Project Setting" so I guess I have to
go for "Javadoc". However I can add anything, I can't get rid of the
error. I just want easy access to the JDK/Spring-Javadocs. What point am
I missing?

TIA,
-hs

3 comments
Comment actions Permalink

For JDK and global library javadocs, look in Settings -> JDK & Global
Libraries and make sure the path to the javadocs is correct. Specifically,
if you point to a jar or zip, make sure that there's no extra directories
above the actual javadocs.

"Hynek Schlawack" <hynek@usenet-2005.ularx.de> wrote in message
news:pbikq2-d7j.ln1@squirrel.hn.org...

Hi,

>

I have a somewhat stupid problem and according to Google and the KB I'm
the only one...

>

I'd like to use "External Javadoc" (aka Shift-F1) but when I press it on
classes/methods that are not from my project, I get a "The documentation
for this element is not found.\nPlease add all the needed paths to API
docs in Project Settings.".

>

Well, there is no "API docs" in "Project Setting" so I guess I have to go
for "Javadoc". However I can add anything, I can't get rid of the error. I
just want easy access to the JDK/Spring-Javadocs. What point am I missing?

>

TIA,
-hs



0
Comment actions Permalink
  • Brad wrote:



For JDK and global library javadocs, look in Settings -> JDK & Global
Libraries and make sure the path to the javadocs is correct.
Specifically, if you point to a jar or zip, make sure that there's no
extra directories above the actual javadocs.


Thanks a bunch Brad, I was apparently totally mislead by the error
message! It works like a charm now.

-hs

0
Comment actions Permalink

np.

"Hynek Schlawack" <hynek@usenet-2005.ularx.de> wrote in message
news:r9mkq2-rkm.ln1@squirrel.hn.org...
>* Brad wrote:
>

>
>> For JDK and global library javadocs, look in Settings -> JDK & Global
>> Libraries and make sure the path to the javadocs is correct.
>> Specifically, if you point to a jar or zip, make sure that there's no
>> extra directories above the actual javadocs.
>

Thanks a bunch Brad, I was apparently totally mislead by the error
message! It works like a charm now.

>

-hs



0

Please sign in to leave a comment.