Hide other databases

Hello !
Is it real to hide in "Database" right bottom window all databases except  one, with which i have connectio in properties ?
In attachment i tried imaginate what i mean, dont show nothink except one DB with wich i working.



Attachment(s):
db.png
7 comments
Comment actions Permalink

Hi there,

Choose "Data Source Properties" and there, on "Schemas & Tables" tab untick all unwanted elements.

0
Comment actions Permalink

Ou, Thansk for your fast reply !
You as always helped me, thanks ! (:

0
Comment actions Permalink

Sorry, one more small question, but is it real to let IDE know database with which i work, and dont always wrie "USE mydatabase;" ?
When i now trying to create table, they show me error, that i didnt choose DB ("[2014-06-18 17:41:18] [HY000][1046] No database selected"), meanwhile i set in "Schemas & Tables" this databse to default, and uncheck all others. But they still ask me to choose database. And when i try for example to INSERT record into DB, autocomplete dont show me tables in this "default" database, but show me this database with dot, and only after this, show tables in there.
Is it real to let IDE know default database, and dont need to set "USE database;", and let autocomplete reconize all tables in this DB ?

0
Comment actions Permalink

Please show me screenshots of your Data Source Properties (that "schemas & tables" tab in particular)

0
Comment actions Permalink

Ofcourse, here it is



Attachment(s):
Untitled.png
0
Comment actions Permalink

Settings are OK -- should be working ... (works OK for me, as far as I can tell)

Please try:
1) Refresh button on Database tool window
2) "File | Invalidate Caches..." and restart IDE

If still nothing -- you could try v8 EAP build -- PhpStorm EAP (can be run alongside to v7 as it uses separate folders for configs and stuff; just backup project settings (.idea subfolder) if you plan to go back to v7 after opening this project in v8 -- some project settings may get lost when going to previous version)

0
Comment actions Permalink

Again big thank you, all work ! :)

0

Please sign in to leave a comment.