PHPstorm Losing Connection (Interpreter)

Hey,

I've been having this problem with PHPStorm,

I'll create a script in phpstorm,  i'll run it in the browser and it will work the first 2-3 times, but then it just gets stuck loading.

The only way to recover is by resetting my Interpreter. However, it soon happens again.

I've also reset my cache, and it helps, but shortly after I'm back at the problem.

I don't know what the problem is, I've set up phpstorm correctly and everything works.

This is the only problem I have, and it happens very often, whether my script has errors or not.


I'll edit with screenshots to hopefully clarify and figure this out much more efficiently.

What I mean by stuck loading:
stuck loading.jpg

I use the icons in the IDE to get to the browser:


access.JPG

PHPSTORM SETTINGS:

Interpreter Settings:
interpreter settingsJPG.JPG



Apache Settings:

apache settings.jpg


Okay, everything should be added  && updated.

Message was edited by: Dawson Hayes

10 comments

And can you check httpd.config Apache file for DocumentRoot path (e.g.I needed to change it from C:\xampp\htdocs to: C:\Users\liubov.melnikova\PhpstormProjects) ?

0

Hi there,

You are using PhpStorm's own built-in simple web server (localhost:63342 kind of address). Possibly it is unable to handle your file upload for some reason or whatever (no ideas).

If you want to use your actual Apache web server from your WAMP instead -- you need to mark your deployment entry as Default for this project (Settings | Deployment). Until then PhpStorm will be using built-in web server by default.

0

I'm not really sure how to check for this?

I'll edit if I find this before you
or someone replies

0

Okay, I'm somewhat confused by what that means,
as in, don't use anything for deployment?


Also, I accidently set a mapping as default,
How do i undo this? lol..

I'll add a pic in just a second..

http://i.imgur.com/HQhXB4m.png?1

Wow it's big, but okay as you can see, the highlighted is what I accidently set.
I originally had it at C://....\PhpstormProjects

And by default, do you mean just don't use that?

0

You have said that you want to use Apapche from your WAMP. Right now PhpStorm does not use it. If you mark your deployment entry as Default .. it will be using different kind of URL (e.g. "localhost/file.php" instead of "localhost:63342/project/file.php")

0

Okay, that's what I thought it was, but it's very hard to read,...


EDIT:

I pasted it into hastebin and it beautified it.


Search found this

DocumentRoot "c:/wamp/www/"

EDIT:
So I changed it to,
DocumentRoot "C:\Users\Dawson\PhpstormProjects"


trying it now..

0

I created a new Deployment, just set it to local or mounted folder, that was it

is that what you mean?

or how do i set it up as default? Just don't select anything from the list?

Here's a pic..

http://i.imgur.com/mvrEWSl.png?1


EDIT:

If you mean "use default"
As in, don't set any mappings in the Deployment >> mappings,
Then, Yeah, I let PHPstorm fill those in. I don't touch that part.

0

So, i changed my httd.conf file,

FROM

DocumentRoot "c:/wamp/www/"

EDIT:
So I changed it TO,

DocumentRoot "C:\Users\Dawson\PhpstormProjects"



and i tried creating a new project "newproj test"
created a test.php file,
added this code:

<?php
phpinfo();

?>

and opened it in browser by hitting the chrome button in the editor,

and it's back at "loading" permanently.

0

Alright well,

I tried doing this :

rechanging the httpd.conf back to

DocumentRoot "c:/wamp/www/";

THEN, I set a deployment to
In Place,
( settings > deployment > green + == "test" , " In Place " then the Web Server Root URL is: http://localhost    )

I tried to click open, didn't work... could not connect to WAMP page.
So that was the reason I went back to change the DocumentRoot back to

DocumentRoot "c:/wamp/www/"


Went back to deployment, clicked open, and it brought me to the wamp homepage, so I knew it worked.

However, tried running a script with phpinfo();
forever loading,

then I thought maybe if  I changed the project's document root to C:\wamp\www\"project's name"

Tried to Re-run the script,
Still, didn't work..

EDIT:
also, after everytime I changed any of the httpd.conf files or settings in phpstorm, I reset all WAMP services and I've tried making a new project with the changes I wanted, still no luck.

0

Please sign in to leave a comment.