PhpStorm debugs everything on server. How do I restrict to project files?

I have the Chrome Jetbrains Plugin installed. When I start listening to debug connections in Storm, it debugs everything that's running on it including the MAMP home page etc.

The "force break at first line when no path / a script outside" checkboxes under xdebug in the Storm config are both unchecked.

I've had this problem before but I can't solve it. I couldn't find anything on google either, which is very surprising.

How do I restrict the debugging scope?

Thanks!

2 comments

Hi there,

That second one should have worked (I would expect it to do so)...

Since I don't know how exactly you have it set up ... I may only suggest this:

1) "Preferences | PHP | Debug --> Ignore external connections through unregistered server configurations" --- try unchecking it

2) "Run | Break at first line in PHP scripts" -- try checking and unchecking it few times (sometimes it shows wrong status). I just not sure if this is related to your issue or not.

3) Show your xdebug settings (corresponding section of output of phpinfo())

0

Thank You!

Annoyingly I don't totally understand what I've done but it works. I checked and unchecked the boxes a few time.

I've enabled "Ignore external connections through unregistered..." (I believe this had been disabled). The other two boxes remain unchecked.

I disabled the "Ignore external" to make sure that my project is added and the server configured. Then I enabled it and now everything works as intended.

Thanks for you help!

0

Please sign in to leave a comment.