6 comments
Comment actions Permalink


1°/ Download the jdk
http://www.apple.com/support/downloads/java2se50release1.html
, and the doc
http://www.apple.com/support/downloads/
java2se50developerdocumentation.html

2°/ Install the 2 packages downloaded above

3°/ To start IDEA with java 5.0:

/Applications/Utilities/Java/J2SE 5.0/Java Preferences
Tab: "general"-"Java Application Runtime Settings"
drag J2SE 5.0 above J2SE 1.4.2

Note: typing "java -version" in the terminal will still return:
java version "1.4.2_07"


4/Compiling java code with J2DE 5.0:

4.1 create a JSDK 5.0:
Create a new JSDK, and point to
/System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home

Note: Due to a a bug, you have to add the 2 doc jars manually:

/System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/appledocs.jar
/System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/docs.jar

The bug: http://www.jetbrains.net/jira/browse/IDEA-1718

4.2, the rest is not mac specific:
in "Project Settings"."Path":
"language level for project.. (effective on restart) "
in "Project Settings"."Compiler":
"use generics-eneabled compiler",



0
Comment actions Permalink

5.0 doesn't seem to work with the release version of Idea just the EAP.

0
Comment actions Permalink

I remember the IDEA 4.5 specs mentioned support for Java 1.5

0
Comment actions Permalink

It's a different thing. 4.5 will only run under 1.4 itself but allows development
of 1.5 projects

-


Maxim Shafirov
http://www.jetbrains.com
"Develop with pleasure!"

I remember the IDEA 4.5 specs mentioned support for Java 1.5



0
Comment actions Permalink

So this means, that java developers on OSX should not
upgrade to java 5.0 until IDEA 5.0 comes out?

0
Comment actions Permalink

Not necessarily - It only means that the current release version of Idea doesn't work with Java 1.5 on the Mac.

0

Please sign in to leave a comment.