Intellij IDEA crashes when remote debugging ruby and java

Hello,

I'm using Intellij 10.5.1 with the Ruby plugin, and I've set up 2 remote debug configurations (1 remote ruby debugger and 1 remote java debugger) to debug my rails app. However when I step through my code I consistently see weird behavior, such as breakpoints being missed and IDEA simply exiting without an error message. I've attached the idea log file, although I'm not sure if it provides anything useful.

I run my rails app with the following options:
jruby -X+O -J-Djruby.reflection=true -J-Djruby.compile.mode=OFF -J-Djruby.debug.fullTrace=true -J-Xdebug -J-Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=58381 -J-cp %CLASSPATH%;%YUICOMPRESSOR_JAR% --debug C:\dev\OnDemand_PI\src\v9\Oxygen\jruby-1.5.1\lib\ruby\gems\1.8\gems\ruby-debug-ide-0.4.10\bin\rdebug-ide --port 58391 -- C:\dev\OnDemand_PI\src\v9\constellation\whohar\script\runner "Cstar::pbe_server" -J-server -e development

When I run my rails app with only the java debugger though:
jruby -J-Xdebug -J-Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=58381 -J-cp %CLASSPATH%;%YUICOMPRESSOR_JAR% -S script\runner "Cstar::pbe_server" -J-server -e development

Then I don't see anymore crashes and all my breakpoints break as expected.

My question is, is this a known issue? If not, Is there additional IDEA debug logs I could enable to send to the jetbrains team?

Thanks,
Justin



Attachment(s):
idea.log.zip
2 comments
Comment actions Permalink

Unfortunatelly noting usefull in idea log except some unparser crasy version number in some your schema.rb file (smth like arrays concatenation?)

Please launch RubyMine from console, most likely crash report/error will be shown there.

0
Comment actions Permalink

Thanks for the tip.
Here's my console output and the jvm crash log.

I noticed the perm gen was at 99% (even though it's set to 250MB), so I adjusted it to 350MB and it still crashed with 99% perm gen used. I've attached my second crash log as hs_err_pid_12860.log if you want to compare.



Attachment(s):
hs_err_pid12860.log.zip
hs_err_pid12440.log.zip
intellijConsoleOutput.txt.zip
0

Please sign in to leave a comment.