Connecting to Debugger..

I use the Ruby plugin for IntelliJ, and when I try to debug a script, the "Connecting to Debugger" dialog comes up and the progress bar goes to the end.
Then, I get this message:

Cannot connect to the debugged process in 10s:

Dumping and destroying process, when the debuggee process is running. You might try to increase the timeout. Killing...

Error Output:
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require': no such file to load -- ruby_debug.so (LoadError)
 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
 from /usr/lib/ruby/gems/1.8/gems/ruby-debug-base-0.10.3/lib/ruby-debug-base.rb:1
 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
 from /usr/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.4.9/lib/ruby-debug-ide.rb:5
 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
 from /usr/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.4.9/bin/rdebug-ide:7
 from D:/Programs/cygwin/bin/rdebug-ide:19:in `load'
 from D:/Programs/cygwin/bin/rdebug-ide:19
 from -e:1:in `load'
 from -e:1



The ruby-debug-ide installed successfully. It used to work, but the only change I've made is I've switched from the One-Click installer version of Ruby to the cygwin version. Running the script works fine, but I don't understand why debugging has that timeout message.
2 comments
Comment actions Permalink

Hi,

What exactly version of IDEA and Ruby plugin do you use?
Are you able to debug using cygwin plain command line? Most likely you have some gems configuration fault.

Regards,
Oleg

0
Comment actions Permalink

I am seeing the same problem too.

I can start the server with "ruby script/server" in cygwin but not inside IntelliJ. Here are my configurations:

Intellij 8.1.3

$ gem list -l ruby

*** LOCAL GEMS ***

ruby-debug-base (0.10.3)
ruby-debug-ide (0.4.9)
ruby-openid (2.1.7)
rubyforge (2.0.3)

0

Please sign in to leave a comment.