Debugging in Tomcat

I once again trying to debug a web service running in Tomcat. I'm getting
some nasty errors trying to start Tomcat when using the debug options that
IDEA gave me. My startup options are:

-Dcatalina.home=C:\Java\Tomcat 5.5.7
-Djava.endorsed.dirs=C:\Java\Tomcat 5.5.7\common\endorsed
-Djava.io.tmpdir=C:\Java\Tomcat 5.5.7\temp
-Xdebug
-Xnoagent
-Djava.compiler=NONE
-Xrunjdwp:transport=dt_socket,address=coltsjuday:4991,suspend=y,server=y

The error I'm getting is:

FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=JVMTI_ERROR_INTERNAL(113)

This may well be a Tomcat issue, but googling the issue (http://www.google.com/search?q=FATALERRORinnativemethod%3AJDWPNotransportsinitialized%2C+jvmtiError%3DJVMTI_ERROR_INTERNAL%28113%29&sourceid=mozilla-search&start=0&start=0&ie=utf-8&oe=utf-8&client=firefox-a&rls=org.mozilla:en-US:official)
only returned 4 links, all for issues regarding NetBean or IDEA.

Thanks for any help provided.

Tobin
(Disclaimer: I am very new to Tomcat development, so this could be something
really dumb)



4 comments
Comment actions Permalink

sorry, I just don't know why you are wrong, cause I was trapped in the same situation a few days before.
But after reading some JPDA articles, I got the answer that satisfied me (maybe not you :).
This is a recommended one : http://java.sun.com/j2se/1.4.2/docs/guide/jpda/conninv.html
You can always find it in your J2SDK directory.

Oh, so poor English. Jump to the solution now.

first, forget the Options that IDEA supplies, and start tomcat with:
-Dcatalina.home=C:\Java\Tomcat 5.5.7
-Djava.endorsed.dirs=C:\Java\Tomcat 5.5.7\common\endorsed
-Djava.io.tmpdir=C:\Java\Tomcat 5.5.7\temp
-Xdebug
-Xnoagent
-Djava.compiler=NONE
-Xrunjdwp:transport=dt_socket,address=4991,suspend=n,server=y

second, In IDEA, create a Remote RunConfiguration and choose "Attach" mode. Use the IP or name of the tomcat server for "HOST" and 4991 for "PORT"

last, Run this Remote RunConfiguration, and you will attach to your remote tomcat server.

0
Comment actions Permalink

warbaby -

Thanks so much for the help. I'm busy with some other task right now so
I can't go try this out, but as soon as I get a chance, I will look at this.
I'm not ignoring you =)

Tobin



0
Comment actions Permalink

hehe ,you are welcome:)

0

Please sign in to leave a comment.