Reformat code Ctrl+Alt+L is not working

Hi,

Recently I upgraded to IntelliJ from that time , when I do ctrlaltL for reformat, it is not working. But it works fine when I do it using menu bar going to tools and clicking on reformat code.

Any one have any idea why this is happening. This is driving me nuts, I am so used to this , i need to fix this.

Any input is highly appreciated.

thanks
-Siva

5 comments
Comment actions Permalink

Did someone have Mouse Without Border?

Ctrl-Alt-L, Ctrl-Alt-R etc... are shortcut for this app an block the key for other application.

I disabled every shortcut in MWB and now the JetBrain shortcut work as well as usual.

If you don't have MWB look if another app may do the same problem!

A+

Ben

1
Comment actions Permalink

Sorry the version I upgraded it to is IntelliJ4.5 from IntelliJ4.0

0
Comment actions Permalink

Hello Siva,

Recently I upgraded to IntelliJ from that time , when I do ctrlaltL
for reformat, it is not working. But it works fine when I do it using
menu bar going to tools and clicking on reformat code.

Any one have any idea why this is happening. This is driving me nuts,
I am so used to this , i need to fix this.

Any input is highly appreciated.


Some video drivers register Ctrl+Alt-* shortcuts for their actions,
thus preventing other applications from using these keys (ATI video
drivers and Intel Extreme Graphics are known to cause this).

The solution is to either locate the application that takes over these
keys and shut it down or assign different key combinations for actions
which do not work in Settings | Keymap.

So, it's rather your system configuration issue, than IDEA problem.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

I got used to hitting alt, 'D', 'L' instead (not the directions, the actually letters). These are
the keys to activate the menu itself, which brings forth the same end as ctrlaltL. Might be an
acceptable solution if you can't affect the settings on your machine.

-Fred

Serge Baranov wrote:

Hello Siva,

>> Recently I upgraded to IntelliJ from that time , when I do ctrlaltL
>> for reformat, it is not working. But it works fine when I do it using
>> menu bar going to tools and clicking on reformat code.
>>
>> Any one have any idea why this is happening. This is driving me nuts,
>> I am so used to this , i need to fix this.
>>
>> Any input is highly appreciated.


Some video drivers register Ctrl+Alt-* shortcuts for their actions,
thus preventing other applications from using these keys (ATI video
drivers and Intel Extreme Graphics are known to cause this).

The solution is to either locate the application that takes over these
keys and shut it down or assign different key combinations for actions
which do not work in Settings | Keymap.

So, it's rather your system configuration issue, than IDEA problem.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Sorry, alt, D, F, that is.

Fred Faber wrote:

I got used to hitting alt, 'D', 'L' instead (not the directions, the
actually letters). These are the keys to activate the menu itself,
which brings forth the same end as ctrlaltL. Might be an acceptable
solution if you can't affect the settings on your machine.

-Fred

Serge Baranov wrote:

>> Hello Siva,
>>
>>> Recently I upgraded to IntelliJ from that time , when I do ctrlaltL
>>> for reformat, it is not working. But it works fine when I do it using
>>> menu bar going to tools and clicking on reformat code.
>>>
>>> Any one have any idea why this is happening. This is driving me nuts,
>>> I am so used to this , i need to fix this.
>>>
>>> Any input is highly appreciated.
>>
>>
>>
>> Some video drivers register Ctrl+Alt-* shortcuts for their actions,
>> thus preventing other applications from using these keys (ATI video
>> drivers and Intel Extreme Graphics are known to cause this).
>>
>> The solution is to either locate the application that takes over these
>> keys and shut it down or assign different key combinations for actions
>> which do not work in Settings | Keymap.
>>
>> So, it's rather your system configuration issue, than IDEA problem.
>>
>> --
>> Serge Baranov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>
>>

0

Please sign in to leave a comment.