Unable to start PhpStorm, Python error in phpstorm.sh

On Ubuntu 14.04, I'm unable to start PhpStorm usign the provided phpstorm.sh script.

After a few second, the script fails with the following error:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site.py", line 68, in <module>
    import os
  File "/usr/lib/python2.7/os.py", line 398, in <module>
    import UserDict
  File "/usr/lib/python2.7/UserDict.py", line 83, in <module>
    import _abcoll
  File "/usr/lib/python2.7/_abcoll.py", line 11, in <module>
    from abc import ABCMeta, abstractmethod
  File "/usr/lib/python2.7/abc.py", line 8, in <module>
    from _weakrefset import WeakSet
ImportError: No module named _weakrefset

Python 2.7.6 is installed.

I tried installing the weakrefset package for Python using pip (`sudo pip install weakrefset`), without success.

I also tried editing the phpstorm.sh script to force usage of Python 3 (3.4.0) without success (no error, the script just consume 100% CPU and nothing happens).

Comment actions Permalink

See http://youtrack.jetbrains.com/issue/WI-17260
It's a problem of python-virtualenv that was fixed in python-virtualenv - 1.4.9-3ubuntu1. Please see: https://bugs.launchpad.net/ubuntu/+source/python-virtualenv/+bug/662611.

Comment actions Permalink

was not installed on my system. Installing
does not fix the issue in my case.
Comment actions Permalink

I broke my phpstorm.sh by using its path as the path for launcher script during first run. Restoring the original phpstorm.sh script solve the issue.

Comment actions Permalink

I can confirm this behaviour - PHPStorm suddenly stopped working after attempting to create a launcher shortcut.

Liubov Melnikova
Comment actions Permalink

Please comment on tracker, so developer will know that this issue is common: http://youtrack.jetbrains.com/issue/WI-17260


Please sign in to leave a comment.