PHP Settings don't stick

I set the PHP interpreter and there are no errors. I click 'OK'. Then I go back to the settings and find that there isn't a PHP interpreter set. What is making this not persist?

4 comments

I looked at the PHP errors and I get:

[29-Apr-2014 05:53:55 America/Los_Angeles] XDebug could not open the remote debug file ''.

Repeated a number of times.

0

It is setup exactly like I setup for a machine that uses Apache instead. I am not using code coverage. I have the same problem whether I try to set XDebug or not. It seems the problem now is that the PHP interpreter cannot be set.

When I do to the settings and click on PHP I select the path to the interpreter and the IDE reports that XDebug 2.3 is enabled. The problem seems that the setting doesn't stick. When I go back to the PHP/settings I see that the PHP interpreter is not set but the drop down remembers the path. So I select the path and the IDE shows no errors

0

Looks similar, please check: http://youtrack.jetbrains.com/issue/WI-22913 .
Vote/comment, if this is your issue.

0

Please sign in to leave a comment.