Can not resolve merge conflicts

Hello...

we're testing PhpStorm in our company.

Now I have forced a merge conflict, to see the handling in PhpStorm.

PhpStorm is showing me the conflict dialog window with the listed files (buttons 'accept yours', accept theirs', 'merge' and 'cancel').

I select the file and click on 'merge' to resolve the conflicts.

After resolving the conflicts in the next window, the conflict dialog comes to the foreground and then PhpStorm 'hangs'.

I working on a Mac with two desktops. When I switch to the other desktop and switch back, I can see for a very short time (under 1 second) a dialog inside the conflict dialog window with two buttons. But this dialog disappears.

So what I must do to resolve the conflict.

Best regards

3 comments

I have found a possible solution.

After changing the java version from 1.6* to 1.7* with witch one PhpStorm will started, the dialog window to save the changes comes normal to the front and I can save and continue.

But now I want commit the changes (to resolve the conflicts) and this commit failed with the error 'cannot do a partial commit during a merge'.

Changing back to java 1.6* results in the same error.

Must I use another way to complete the merge process?

0

Thanks for this hint.

The other problem with the commit have I solved with sourcetree.

0

Please sign in to leave a comment.