How debug node.js application in webstorm 8

I used webstorm 7.0.3, now I'm trying Webstorm 8, but I can't debug my application anymore.

My breakpoints don't have any effet, I imported my config from the 7th version. If I use the 7th version my breakpoints work correctly.
There is no difference between both debug configurations.

What am I missing?

6 comments

What does your run configuration look like? Is the issue specific to your project? Please check if it can be recreated in a Node.js Express application created with File/ New project/Node.js Express app

0

This is my config:

https://docs.google.com/file/d/0ByzbHcAxmCyveXkzdnI3OE1QRG8

I tried more and sometimes it works, on start, but no on live.
Meaning that if I create a breakpoint on something that is loaded while the server starts, it works.

If I create a breakpoint on a controller and I refresh the view, it doesn't. While it does work if I do the same in 7.0.3.

0

Works for me - when I load the http://localhost:1337 in browser and touch the controls (enter text, for example), breakpoints in controllers are hit
Please can you attach the sample project that shows up your issue?

0

I just tried several things.

I created a new project and it worked, so I tried to figure out why my actual project doesn't.

Here is the code:

public static admin(req, res){             Home.super(req, res, function(req, res){                 req.session.user.connected = true;
            }
}  


If I set a breakpoint line 2 (Home.super) it is not triggered.
If I set a breakpoint line 3 it is triggered.

This was with the 8.0.1 version, now if I do the same with the 7.0.3, both are triggered.

N.B: The source code is javascript, but wrote with typescript. (OOP oriented)

0

Seems I still need a project to figure out the problem...Can you upload it to ftp,  or create a support ticket?

0

I can't, this project is way too big and private.

0

Please sign in to leave a comment.