Upgrading to jdk 1.5

Hi
I am running IDEA 4.5.3 build 2250. I installed jdk 1.5.0_01. I made the necessary changes to my path and project. However, it doesn't appear that my project is compiling with jdk1.5 because I am getting compile errors. The path in my debug window shows jdk1.5, my project path module-specific JDK shows 1.5, the jar files listed indicated they are 1.5. I think this might be a registry issue. (I am on Win 2000). On my machine I have uninstalled previous jdk's, rebooted, reinstalled 1.5, and reinstalled IDEA. Has anyone else seen this behavior?

4 comments
Comment actions Permalink

Please checkout language level combo at the bottom of the Settings|Path dialog.
Should be set-up to 5.0 to gain 5.0 language features.
-


Maxim Shafirov
http://www.jetbrains.com
"Develop with pleasure!"

Hi
I am running IDEA 4.5.3 build 2250. I installed jdk 1.5.0_01. I made
the necessary changes to my path and project. However, it doesn't
appear that my project is compiling with jdk1.5 because I am getting
compile errors. The path in my debug window shows jdk1.5, my project
path module-specific JDK shows 1.5, the jar files listed indicated
they are 1.5. I think this might be a registry issue. (I am on Win
2000). On my machine I have uninstalled previous jdk's, rebooted,
reinstalled 1.5, and reinstalled IDEA. Has anyone else seen this
behavior?




0
Comment actions Permalink

Thank, I had already set this and I have already tried adding -Didea.no.jdk.check=true to the jvm args. No change in compile error.

0
Comment actions Permalink

DD> -Didea.no.jdk.check=true

This switch is only used if you want Idea itself to run under 1.5.

For compiling/running your code, this isn't necessary.




0
Comment actions Permalink

I have solved this issue. Even though I had removed the previous version of JDK from my machine, the registry did not get cleaned up correctly. Also, there were some old JRE's in the registry. Once I removed all the JDK's and JRE's in the registry, rebooted my machine, then I installed JDK 1.5. This did the trick.

0

Please sign in to leave a comment.