[UPDATED] PHPStorm very slow to startup. Anyone else getting this too?

Hello everyone!

Macbook Pro 2010 (i7 with 8GB RAM)
Mac OSX 10.7.5 (Lion)
PHPStorm 5.0.4

I bought PHPStorm a few months ago and have been very happy with it.  My only major gripe is that it takes "ages" to load up.  It takes almost exactly 2m30s to start every time.  I suspect something is waiting on a timeout but I've no idea what.  Here are the logs (I can supply more if needed):

2012-12-11 15:23:07,843 [      0]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE STARTED ------------------------------------------------------
2012-12-11 15:23:07,987 [    144]   INFO -        #com.intellij.idea.Main - IDE: JetBrains PhpStorm (build #PS-121.390, 30 Oct 2012 00:00)
2012-12-11 15:23:07,987 [    144]   INFO -        #com.intellij.idea.Main - JRE: 1.6.0_37-b06-434-11M3909 (Apple Inc.)
2012-12-11 15:23:07,987 [    144]   INFO -        #com.intellij.idea.Main - JVM: 20.12-b01-434 (Apple Inc.)
2012-12-11 15:23:07,987 [    144]   INFO -        #com.intellij.idea.Main - JNA library loaded (64-bit) in 0 ms
2012-12-11 15:23:08,050 [    207]   INFO -        #com.intellij.idea.Main - Snappy library loaded (1.0.4) in 63 ms
2012-12-11 15:23:39,006 [  31163]   INFO - llij.ide.plugins.PluginManager - Cannot find optional descriptor coffee-jsintentions.xml
2012-12-11 15:24:42,550 [  94707]   INFO - llij.ide.plugins.PluginManager - 40 plugins initialized in 94223 ms
2012-12-11 15:24:42,551 [  94708]   INFO - llij.ide.plugins.PluginManager - Loaded plugins:IDEA CORE, Apache config (.htaccess) support (121.390), CSS Support, JavaScript Support (1.0), JavaScript Intention Power Pack (0.9.4), Inspection-JS (2.0), XPathView + XSLT Support (4), IntelliLang (8.0), UML Support (1.0), LESS support, Remote Hosts Access (0.1), SASS support, JavaScript Debugger (1.0), LiveEdit (1.0), PHP (121.390), Command Line Tool Support (121.390), Database Support (1.0), Framework MVC Structure Support (121.390), Git Integration (8.1), Task Management (1.0), GitHub, HTML Tools (2.0), Phing Support (121.390), QuirksMode, ReStructuredText Support, SQL support (1.0), W3C Validators (2.0), YAML
2012-12-11 15:24:42,551 [  94708]   INFO - llij.ide.plugins.PluginManager - Disabled plugins: ASP (0.1), CoffeeScript (2.0), Base Cucumber (1.0), CVS Integration (11), HAML, hg4idea (10.0), Java Server Pages Integration (1.0), GNU GetText files support (*.po) (VERSION), Perforce Integration (2.0), Refactor-X (2.01), Subversion Integration (1.1), XSLT-Debugger (1.4)

So what actually happens:

  1. I click the icon to start up PHPStorm.  Nothing happens for exactly (suspiciously exactly) 60 seconds.
  2. Then at 15:23:07 the loading screen appears with the loading progress bar stuck very close to the start (at about the 3% mark).
  3. 30 seconds later (15:23:39) the loading bar moves quickly to about 33% full.  Here it stops again and I wait for just over 60 seconds.  
  4. Then (at 15:24:42) the progress bar rapidly fills up to 100% and PHPStorm loads.  At this point I see a notification from my OXS firewall asking me to allow PHPStorm to recieve incoming connections which I accept.

I think that the inital 60 second wait, then the 30 second wait and the following 60 second wait are all timeouts of some description.  I have no idea what for though.

The fact that the OSX firewall asks me to accept incoming connections after PHPStorm loads makes me think it may have been blocking it during the loading phase and hence the waiting.  Assuming that is the problem, despite adding PHPStorm to my firewall settings permanently this notice still displays everytime.  There is a problem with apps not being signed (or something, I don't really understand) and so OSX displays this notice.

Anyway, I have totally ASSUMED that it's the OSX causing this long load up time.  Perhaps PHPStorm is just this slow for everyone?

BTW once PHPStorm has loaded it's very fast and I have no problems with it.

Any help is gratefully recieved.  Especially if you can identify the real problem here and not just my speculation.

[UPDATE: I just quickly deleted PHPStorm from my Applications directory, downloaded a new copy and reinstalled it.  Apparently that is the typical way to fix that firewall "netowrk connections" notification and sure enough it worked!  No more notifications.  However, everytime I start PHPStorm and the same timeouts are occuring!  It seems disabling the firewall is the only way to stop these timeouts from happening.  Arggh!!]

Message was edited by: Red Leader


Please upload a CPU snapshot for your problem (see http://devnet.jetbrains.net/docs/DOC-192).


Those instructions appear very out of date (Jan 2006 - that's almost 7 years ago!).  Are they still relevant?


I can't seem to upload my CPU snapshot here.  It's 14MB but despite the 15MB limit I can't seem to upload it here...

Those instructions appear very out of date (Jan 2006 - that's almost 7 years ago!).  Are they still relevant?

Created on: 26-Jan-2006 03:04 by Serge Baranov - Last Modified:  16-Aug-2012 16:15 by Serge Baranov

I can't seem to upload my CPU snapshot here.  It's 14MB but despite the 15MB limit I can't seem to upload it here...

You can upload it to FTP -- address and instructions are in that document (close to the end).


It seems http://youtrack.jetbrains.com/issue/IDEA-96834 is the cause, so don't bother w
ith snapshot


Thanks for your help guys.  It was indeed the firewall on my Mac.  Simply disabling it and starting PHPStorm proved it - it loaded almost instantly!  The moment I turned the firewall back on OSX asked me to Allow/Deny network connections to PHPStorm.

There is definitely a bug here though.  Adding PHPStorm to the OSX Firewall doesn't change the fact it still blocks it!  However, it feels more of an OSX bug than a PHPStorm bug.  Although there might be something PHPStorm could do to the Mac version to make it play nicer with the firewall??  :)


I'm having very slow load times as well, over three minutes. My projects are quite small, and there is plenty of memory available. I deleted several unnecessary .idea folders, and rebuilt the cache, to no avail. I also tried turning off the firewall, but that made no difference. PHPStorm worked very well until a few days ago.

How do you capture CPU loading data? Following these instructions (http://devnet.jetbrains.com/docs/DOC-192) I made the change to info.plist on OS 10.8.2, and I can turn on Capture CPU Usage Data, but shutting down and restarting PHPStorm does not produce a log file, only activities done within the program create a log.


I've found my issue with very slow switching between tabs. The reason was a GitFlow Integration plugin. After i disable it - finally things get back. Now i easily again can switch between tabs and scroll and input code even the IDE doesn't loaded fully, after i start it up


Please sign in to leave a comment.