Cannot load grunt tasks - Webstorm 8

After upgrading to Webstorm 8, I cannot load the grunt tasks in one of my folders.
This appears to be related to the directory somehow, as I can execute the grunt command just fine in the terminal window. The error I can is:

grunt.cmd --no-color --gruntfile C:\XXXX\Gruntfile.js --tasks "C:\Program Files (x86)\JetBrains\WebStorm 8.0\plugins\JavaScriptLanguage\grunt_js\tasks" _intellij_grunt_tasks_fetcher
Running "_intellij_grunt_tasks_fetcher" task
Process finished with exit code 0

It appears to be unrelated to the gruntfile.js, if I clear it out, or replace it with the one in another project that works, I still get the same error.

Any suggestions for fixing this?

9 comments

Haven't heard of such issues. Please can you attach the project tht shows its up?

0

Not sure what you meant by project. I attached the workspace.xml file.



Attachment(s):
workspace.xml
0

Same issue here:
grunt.cmd --no-color --gruntfile C:\xxxx\Gruntfile.js --tasks "C:\Program Files (x86)\JetBrains\WebStorm 8.0\plugins\JavaScriptLanguage\grunt_js\tasks" _intellij_grunt_tasks_fetcher
Running "_intellij_grunt_tasks_fetcher" task

Process finished with exit code 0

You can view my Gruntfile here:
https://github.com/boxplayer/eTuneBook/blob/master/Gruntfile.js

It's functional (grunt server or grunt build runs in git bash)

Maybe it's a Yeoman issue? Or a Windows issue?

0

No, the workspace.xml won't help. You wrote that the problem is specific to certain folder - most likely it's somehow related to its content. I need a project I can recreate the problem with - not necessary whole your project, just the reduced version that shows up the issue. If you don't like to publish it here, you can either create a support ticket, or upload the files to ftp ( ftp://ftp.intellij.net/.uploads/ ) and let me know the file name

0

I ran into almost the same issue (exist code 99, instead of 0) and got around the problem by runnig npm intall as Administrator in command prompt.  

Initiall, I used WebStrom's Settings: Node.js and NPM to install packages; wer not able to run grunt.  

Saun

0

I ran npm install grunt --save-dev and npm install as administrator. This upgrade my grunt from 0.4.1 to 0.4.4.
Not sure which of those changes caused it, but I can now load and run grunt tasks.

Thanks,
Bernd

0

Thanks for the uppdate Bernd.  I don't know what exactly caused the change either.  Running npm install as as administrator seems to work consistenly.  

Ideally, using WebStorm Settings: Node.js and NPM: Install Packages should work.  I hope WebStorm team will figure out how to make Install (npm) packages work properly.  

Saun

0

Thanks for the feedback.

grunt.cmd --no-color --gruntfile C:\XXXX\Gruntfile.js --tasks "C:\Program Files (x86)\JetBrains\WebStorm 8.0\plugins\JavaScriptLanguage\grunt_js\tasks" _intellij_grunt_tasks_fetcher
Running "_intellij_grunt_tasks_fetcher" task
Process finished with exit code 0

The issue can be reproduced on Windows with grunt version <= 0.4.1.
Fix will be available in WebStorm 8.0.1.

Workarounds for WebStorm 8.0 users: use grunt version >= 0.4.2 or use node interpreter version >= 0.11.12 (unstable).

0

Just updated to 8.0.1. Now I can see the grunt tasks. Thanks!

0

Please sign in to leave a comment.