Broken Character in console

Hi.

I'm korean, so I used to use Korean character data in my code and data schema on Webstorm.

But when I take a log in console with Korean character,
it was broken something like this.

Test input : console.log("현재화면");
Test output on Webstorm console:
Screenshot 2014-04-06 04.37.01.png

But actually when I copy and paste that string into the text editor from console,
the result is find.

Test output in text editor : I20140406-04:35:40.581(-7)? 현재화면

And, when I run the server in the system consol in my Mac, the result is find also.

Test output in Mac console : I20140406-04:40:28.596(-7)? 현재화면


So I assume that the only problem from here is the character setting of Webstorm console.
And I can't find any difference between the console's setting, Webstrom console and Mac console.

Here's each locale setting both of them.

Webstorm console locale :
LANG="ko_KR.UTF-8"
LC_COLLATE="ko_KR.UTF-8"
LC_CTYPE="ko_KR.UTF-8"
LC_MESSAGES="ko_KR.UTF-8"
LC_MONETARY="ko_KR.UTF-8"
LC_NUMERIC="ko_KR.UTF-8"
LC_TIME="ko_KR.UTF-8"
LC_ALL="ko_KR.UTF-8"

Mac console locale :
LANG="ko_KR.UTF-8"
LC_COLLATE="ko_KR.UTF-8"
LC_CTYPE="ko_KR.UTF-8"
LC_MESSAGES="ko_KR.UTF-8"
LC_MONETARY="ko_KR.UTF-8"
LC_NUMERIC="ko_KR.UTF-8"
LC_TIME="ko_KR.UTF-8"
LC_ALL="ko_KR.UTF-8"


Does anybody knows about this character broken problem?

Thanks in advance.

4 comments

Hello!

what console is meant? Is it terminal (Tools/Open terminal), debugger console, or?

0

I used 2 terminal as I commented-

Webstorm Inner Console. (using option + f12 on Mac)
Mac Console (iTerms2).

The broken problem is in Webstorm Console.

Is that clear? ;)

0

Please sign in to leave a comment.