Updated to WS 8 and now Compass does not work any more

Hello,

I just installed version 8, reimported my project settings from previous version and now the compass/sass integration does not work any more.

I'm using a ruby for windows installation, and thanks to the help of support people I managed to get everything working in WS 7.

I cleared the file watchers, but even in the Settings > Compass support dialog window I get the error "Cannot launch compass executable file".

The path I use is "C:\Program Files (x86)\Ruby200\lib\ruby\gems\2.0.0\gems\compass-0.12.2\bin\compass"

I tried several other ones before and all do produce the same error message.

The "config path" setting on the same dialog points to the correct config.rb

If I manually run "compass compile" on that project path, it compiles fine.

Please help :)

11 comments
Comment actions Permalink

Hi there,

The path I use is "C:\Program Files (x86)\Ruby200\lib\ruby\gems\2.0.0\gems\compass-0.12.2\bin\compass"

On Windows the executable file has to have correct extension to be executable (compared to Mac/Linux with their executable attribute). So it should be "compass.bat" (or .cmd/.exe/etc) instead of just "compass".

0
Comment actions Permalink

Hi and thanks for the fast answer.

WS7 required this specific path to work properly.

Tried updated path to "C:\Program Files (x86)\Ruby200\bin\compass.bat" and that error message is gone now. (just FYI, this path was not working in WS7).

Webstorm then suggested adding the file watcher again, which I accepted.

However now only the main scss file triggers the execution of the "compas scss" task, even though I unchecked the box "track only root files".

Again, it was working perfectly in WS7...

What should I try please ?

0
Comment actions Permalink

However now only the main scss file triggers the execution of the "compas scss" task, even though I unchecked the box "track only root files".

Again, it was working perfectly in WS7...


Could it be http://youtrack.jetbrains.com/issue/WEB-11517 ? Sounds similar for me.

0
Comment actions Permalink

Possibly yes.

Same project same everything was working ok just before update to WS8.

Should I wait for a fix & update then ?

0
Comment actions Permalink
Should I wait for a fix & update then ?

If it would be me then I would still use v7 until it will be fixed (for me its pretty stupid that such bug appeared in final release, especially if it was working OK in previous versions (6 & 7))

0
Comment actions Permalink

Yes well, I uninstalled WS7 before installing WS8, since it has been in pre release state for a while, I figured previously working features would still work ...

0
Comment actions Permalink

>Tried updated path to "C:\Program Files  (x86)\Ruby200\bin\compass.bat" and that error message is gone now. (just  FYI, this path was not working in WS7).

Yes - it was a bug that is fixed in WebStorm8. Now you need to specify " C:\Program Files  (x86)\Ruby200\bin\compass.bat" both in Compass settings and in Compass file watcher. Note that you will probably have to re-save your config.rb after changing the path to get everything re-indexed to make it work

>However now only the main scss file triggers the execution of the  "compas scss" task, even though I unchecked the box "track only root  files".

works fine for me. Please can you attach a screenshot of your file watcher settings? Sample project that shows up the issue would be helpful, of course

0
Comment actions Permalink

This bug only occurs when using a custom file watcher (Grunt) to compile SASS - I have been unable to recreate it using the compass file watcher. My settings attached



Attachment(s):
compassScss.png
0
Comment actions Permalink

Thanks Elena.

Here is the config of the watcher

Untitled.png

Just the default webstorm generated one, with "immediate file sync" and "track only root files" unchecked.

The config.rb file sits in "D:/efficy/diske/WebClient/efficy/scss/config.rb" and the project path inside config.rb is set to the same folder.

0
Comment actions Permalink

Seems the 'track only root files' is the culprit. When it's on, file wather is triggered on modifying partials, and doesn't work otherwise
Added a comment to http://youtrack.jetbrains.com/issue/WEB-11517

0

Please sign in to leave a comment.