Invalid Vcs root mapping

I created a new project from existing files on Ubuntu 12.04

The project structure:

Bildschirmfoto 2014-03-23 um 13.25.37.png

There are two messages:

1. Invalid Vcs root mapping
    The directory <Project> is registered as a Git root, but no Git repositories were found there.

Bildschirmfoto 2014-03-23 um 13.33.25.png



Bildschirmfoto 2014-03-23 um 13.21.22.png

To push the entire project to bitbucket worked for me:

ip@ubuntu:~/Documents/drupal72$ git push origin master
error: unable to create directory for .git/refs/remotes/origin/master
error: Cannot lock the ref 'refs/remotes/origin/master'.

But there is no way to save the local project:

2. Could not save project!: Unable to save project files. Please ensure project files are writable and you have permissions to modify them. Try to save project again.

Bildschirmfoto 2014-03-23 um 13.29.12.png

Additonal I can't clear the Read-Only Status.

Bildschirmfoto 2014-03-23 um 13.29.55.png

It is impossible to choose 'Using version control integration.

Do you know a good configuration how to?


Regards,
bolshii

1 comment
Comment actions Permalink

First of all try File | invalidate caches and restart.

If issue remains, please try to map the git checkout root (the directory with .git) to Git in Settings | Version Control explicitly.
If it still doesn't work, attach idea.log: http://intellij-support.jetbrains.com/entries/23352446 and your .git/config.

0

Please sign in to leave a comment.