Debugging stopped after an upgrade to PHP 5.5.10

As best as I can tell debugging stopped after an upgrade to 5.5.10. Going back to 5.5.7 didn't seem to fix things. I don't get any errors but the breakpoint I set never gets triggered when I know that the code is executing. I have attached a series of screen shots that I think capture my configuration. Can anyone tell me what is wrong? Or how to diagnose the problem? Thank you.

Kevin



Attachment(s):
debug3.jpg
debug2.jpg
debug1.jpg
xdebug4.jpg
8 comments
Comment actions Permalink
Or how to diagnose the problem?

Start collecting logs (from both sides) and look into them.


Invoke breakpoint programmatically -- xdebug_break();

Avoid placing breakpoints on if conditions lines -- place them on "normal" single line statements.

Double check xdebug config (the screenshot you have provided does not show ALL settings)

Restart computer (I know -- sounds stupid, but sometimes works).

0
Comment actions Permalink

I received a PHP error:

[12-Mar-2014 10:10:54 US/Central] Default exception handler: Web server software (PhpStorm 7.1.3) is not supported, sorry. Debug:
Error code: unsupportedwebserver
* line 929 of \lib\setuplib.php: moodle_exception thrown
* line 761 of \lib\setuplib.php: call to setup_get_remote_url()
* line 759 of \lib\setup.php: call to initialise_fullme()
* line 26 of \config.php: call to require_once()
* line 2 of \mod\mediasite\lib.php: call to require_once()

But probably more informative is the attached IDE log. Somehow it is complaining about file path mappings. Where do I set that up? It must have been cleared.

Also eventhough I have a path to PHPUnit.phar the IDE complains that it cannot find PHPUnit.

Thank you.

Kevin



Attachment(s):
idea.log.zip
0
Comment actions Permalink
Default exception handler: Web server software (PhpStorm 7.1.3) is not supported, sorry

As I understand from the message above you are using PhpStorm's own built-in simple web server. It will be much better if you would use proper web server software insetad (e.g. Apache/nginx/IIS/etc).

Please verify your Deployment settings (that's where you can set up URL) -- in case you are opening web pages directly from IDE.

But probably more informative is the attached IDE log. Somehow it is complaining about file path mappings. Where do I set that up? It must have been cleared.

For PHP Debug -- "Settings | PHP | Servers".

Also eventhough I have a path to PHPUnit.phar the IDE complains that it cannot find PHPUnit.

Cannot comment -- you have not provided any info about your PHPUnit setup.


General suggestion: Close IDE and backup & delete project settings (.idea subfolder). Then use "Open Directory" action to open your project and configure it from scratch (You can always restore everything back from backup copy).

0
Comment actions Permalink

Where do I set the Web server? I found this page (attached) but I don't see PHP set as the browser?

I removed .idea and I found PHP -> Servers nothing is configured so I hit '+'. What will this give me? I don't remember doing this before. I have attached a screenshot in case you have recommended settings.

I have also included my phpunit setup.

Thank you.



Attachment(s):
server.jpg
browser.jpg
phpunit.jpg
0
Comment actions Permalink
Where do I set the Web server?

Settings | Deployment

I removed .idea and I found PHP -> Servers nothing is configured so I hit '+'. What will this give me? I don't remember doing this before.

You can delete any records there -- if you going to use Zero-Config debug approach, IDE will help to configure that on first debug connection:


PHPUnit:

I have also included my phpunit setup.

And what PHPUnit version do you use there? Currently IDE only supports PHPUnit 3.7 or older

0
Comment actions Permalink

I went through these steps. I have Xdebug installed and it shows up as being installed. I am using XDebug helper as shown in an earlier screen shot but I still don't hit the breakpoint.
If I set xdebug_break() then I get a chance to set the mappings. I have attached a screenshot of what I see. The mapping is wrong but it doesn't look like I can change it. Where is this in the settings?pathmappings.jpg

Thank you.

0
Comment actions Permalink

I do not know what else to advise you here (without sitting in front of your computer).

You have had the same situation in the past and were able to resolve it somehow -- try again -- http://devnet.jetbrains.com/message/5506630#5506630

0
Comment actions Permalink

The mapping is wrong but it doesn't look like I can change it. Where is this in the settings?

The already mentioned "Settings | PHP | Servers"

0

Please sign in to leave a comment.