Reply to support mail: really slow - moving to eclipse

Hello All,

Someone posted a mail via support forms with the following e-mail
address: Please Put In Forums <reply_in_forums@yoohoo.com>. So I can't
reply directly and posting it here in case he/she reads this group/forum.

From: "Please Put In Forums" <reply_in_forums@yoohoo.com>
Sent: Thursday, June 17, 2004, 4:35:31 PM
To: support@jetbrains.com
Subject: really slow - moving to eclipse

We have a project with 5500 classes. On a fast PC, it takes Idea 3.0 about 7 minutes to start up. What is it doing?

Then, once it is up, when we switch to Idea from using another application, Idea make disk accesses for a couple of minutes locking up the PC. What is it doing?

We have dozens of Idea licenses, but have to switch to Eclipse because it does not have these problems.

I cannot provide my company's identity for competitive reasons.

--
OS: Windows NT/2000
JDK: JDK 1.4.2
IDEA: 3.x
Build:


It is not a normal IDEA behavior. It seems that there is something
wrong with your system or IDEA configuration.

Check the following:

1. Make sure that IDEA caches (USER_HOME\.IntelliJIdea\system) are on
the local drive.

2. Make sure that the project and JDK are residing on the local
drives.

3. Disable Settings | General | Synchronize files on frame activation.

4. Play with the heap size setting:
http://support.jetbrains.com/kb/click.jspa?categoryID=5&entryID=3
http://support.jetbrains.com/kb/click.jspa?categoryID=13&entryID=33

5. Reset IDEA caches by deleting USER_HOME\.IntelliJIdea\system
directory.

6. Perform drive defragmentation.

7. Disable Local VCS.

Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

1 comment
Comment actions Permalink

Step 3 helped me a lot. Maybe it should just be the default case, there is that synch button anyways that can be used just in case.

0

Please sign in to leave a comment.