Auto upload: Failed to change timestamp of the file

I have configured the auto upload on my remote server with PhpStorm and I get this error:

Failed to change timestamp of the file

But the file is uploaded and the update date is updated. So I don't understand the error. I unchecked the case "Ovveride timestamp" in the config.

Any idea?

14 comments
Comment actions Permalink

I've also come across this, can anyone shed some light on this error? And to resolve this?

0
Comment actions Permalink

This usually means that (S)FTP software on your server does not understand timestamp changing command or uses completely different command or format

Please enable debug logging, reproduce issue and attach log here -- this will allow to see what command was sent .. and what server (S)FTP software you have.

Related ticket (possibly your server supports this): http://youtrack.jetbrains.com/issue/WI-1057

0
Comment actions Permalink

I remember that I used OVH mutu server, the basic one. (Perso)
I have no idea what kind of FTP they use.

0
Comment actions Permalink

Well .. if you attach log file it should tell supported commands as well as FTP software used (unless server was configured to not to give away such info).

In any case: AFAIK at the moment  only MDTM command is supported but not UTIME or MFMT.

0
Comment actions Permalink

Here is my attached log.



Attachment(s):
idea.log.zip
0
Comment actions Permalink

Accordingly to your log:

  • I could not find what server software it is (possibly because it was configured to not to display such info)
  • FTP server reports that it supports MDTM command (used for setting timestamp) .. but it does not recognize format used (different order of parameters (unlikely)?? .. or (most likely) it can only return timestamp but unable to modify it -- http://tools.ietf.org/html/rfc3659#section-3.4 )


I may only suggest submitting new ticket to the Issue Tracker and attach this log there -- corresponding developer will investigate it further.

0
Comment actions Permalink

Aye, which is why I was stumped, nonetheless opened a ticket on it along with the log file.

Thanks for looking into this mate.

0
Comment actions Permalink

Thank you so much for your help!

By the way, MFMT is also supported, but this server doesn't support that extension (UTIME won't help it also).

0
Comment actions Permalink
By the way, MFMT is also supported,

I see it now .. after I have checked ALL the comments.

I may only suggest altering the ticket summary (or description) for now (untill fully resolved) to specify this moment (because based on current summary everyone will get wrong impression of the currently supported commands)

0
Comment actions Permalink

I have the same problem:

Failed to change timestamp of the file 'xxxxxxx'

but I bet it is a problem related with file permissions. I am working in two different webs in the same server and the problem only happens in one of them. Both have different file permissions and owner.

0
Comment actions Permalink

Any chance to test file permissions? Does the same happen using 3rd party app (e.g. Filezilla)?

0
Comment actions Permalink

I had the same issue just a while ago... after changing owner and group for /var/www/html/[my_domain] to be the same as my ftp user solved this error at least for now.

2
Comment actions Permalink

old post but i wanted to add my 2 cents. 

I also have this error and discovered it's due to using Filesystem ACL's (setfacl). My deployment directories are owned by "apache" but I have ACL's set so that my user can write to the files. However, Linux doesn't allow non-owners to modify the mtime of files (regardless of what the ACL's are). So, your options are to chown the files to your user, or disable the "preserve file timestamps" in Intellij.

[root@server]# getfacl MainController.php
# file: MainController.php
# owner: apache
# group: apache
user::rw-
user:myuser:rw-
group::rw-
mask::rw-
other::r--
0
Comment actions Permalink

I know it's an old post, but maybe it can help someone.
I don't know if this is the best solution, but the way I found to get around it was to go to [Tools -> Deployment -> Options]
I marked the option "Upload changed files automatically to the default server" as "On Explicit save action (Ctrl + S)".

Now to upload the file to the server, just select it and give [Ctrl + S]

0

Please sign in to leave a comment.