endless indexing when ECMAScript Harmony is enabled in Yeoman generated Angular project.

I created Angular project using yeoman generator and imported it into WebStorm.

My  project has yeoman generated node_modules folder which was recognized by WebStorm and prompted me to create "Node.js Dependencies" JavaScript library from node_modules folder.

So far so good but,  I wanted to write JavaScript code using ES6 syntax.

To support ES6 , I enabled Preferences > JavaScript > and selected ECMAScript Harmony in WebStorm.

This triggered indexing and WebStorm hung with endless indexing on node_modules folder.

I excluded the node_modules from project and also removed node_modules from External Libraries as workaround.


Wonder if any one else faced this problem. is it a known bug?


Here are the step to reproduce  https://github.com/xmlking/angular-webstorm-project-setup
and here is the ES6 code I am trying  http://embed.plnkr.co/E4JVGt/preview

8 comments
Comment actions Permalink

Hello!

I set up the project according to instructions, but switching the javascript version works fine for me: WebStorm gets stuck for a minute, and then I can proceed with my work... Note that I didn't try the ES6 code - just installed all components
Please can you zip your project and upload it somewhere (to  ftp://ftp.intellij.net/.uploads/ , for example)?  must be missing something...
Also, what WebStorm version do you use?

0
Comment actions Permalink

Sorry I also couldnot reproduce it again.
I tried copying the project content to new filder (with out .idea)  and opened the folder as new project in webstorm. -- no endless indexing detected.
In the project that was giving me the problm, I alloved WebStorm to update "Node.js Dependencies" at the following prompt. -- it worked and no endless indexing detected.
   [To separate your sources from the dependencies, create "Node.js Dependencies" JavaScript library from node_modules folder]

So we can close this issue for now. I will post again if I could found how to reprduce it.


By the way after allowing WebStorm to update "Node.js Dependencies", I could not hide the node_modules folder in my project view with

 Setting > Directories > exclude `node_modules` and `.tmp` directories from project.

I dont want to see node_modules in my project view. is there a solution for it?
Screen Shot 2014-02-23 at 9.35.46 AM.png
Screen Shot 2014-02-23 at 9.36.33 AM.png

0
Comment actions Permalink

I am using WebStorm 7.0.3.

 

When problem happened, The indexing took all my CPU and memory. I increased WebStorm memory to 2GB when WebStorm prompted for insufficient memory.

The only way I was able to take control was , kill webStorm and restart it, and quickly went to preferences and disabled ECMAScript Harmony setting.

0
Comment actions Permalink

Same here with WebStorm 7.0.3
Simple traceur project with ONE file and Grunt config - No Yeoman, no Angular
Opened in WS, after switching to ECMAScript Harmony WebStorm hangs doing ... something until I kill process
Delete .idea, open again, switch to ES Harmony - same thing

Makes impossible to develop ES6 with WS

0
Comment actions Permalink

>By the way after allowing WebStorm to update "Node.js Dependencies", I could not hide the node_modules folder in my project view with

 Setting > Directories > exclude 


This is because it's added as a library. Folders marked as libraried are shown in the peoject view even if they are excluded
0
Comment actions Permalink

Please can you attach the project that shows up your issue?

0
Comment actions Permalink

Attached is project (or directory - I deleted .idea folder)
Run npm install BEFORE switching to ECMAScript Harmony
After npm finishes open dir in Web Storm and try to switch to ECMAScript Harmony...



Attachment(s):
ES6.zip
0
Comment actions Permalink

thanks! Unfortunately I can't install the modules - something went wrong with my npm... Please can you check if the problem persists in WebStorm8 EAP (http://confluence.jetbrains.com/display/WI/WebStorm+8+EAP)? Some problems (reproduced with grunt-traceur + harmony) are fixed there

0

Please sign in to leave a comment.