URGENT: EAP or 4.5.2 with EM64T JDK

For a project, I need to use IntelliJ on Redhat (see below), but the JRE that comes with Idea (both EAP & 4.5.2) crashes when I try to start up Idea. (Error log is attached).

Is it possible to use JRE 1.5 (for which a version for the x86_84 exists), or another version of 1.4.2 (like _06) which doesn't crash for me?

Is there any way I can hack this so that I can get at least partial functionality (if that makes sense).

Platform:
Red Hat Enterprise Linux WS release 3
(kernel 2.4.21-15.EL -- x86_64)

Thanks in advance



Attachment(s):
hs_err_pid9232.log
2 comments

Hello Edward,

Adding -Didea.no.jdk.check=true to the JVM_ARGS in your startup script (or idea.lax) will allow you to start IDEA with another JDK.

HTH,
Andrei


EB> For a project, I need to use IntelliJ on Redhat (see below), but the
EB> JRE that comes with Idea (both EAP & 4.5.2) crashes when I try to
EB> start up Idea. (Error log is attached).
EB>
EB> Is it possible to use JRE 1.5 (for which a version for the x86_84
EB> exists), or another version of 1.4.2 (like _06) which doesn't crash
EB> for me?
EB>
EB> Is there any way I can hack this so that I can get at least partial
EB> functionality (if that makes sense).
EB>
EB> Platform:
EB> Red Hat Enterprise Linux WS release 3
EB> (kernel 2.4.21-15.EL -- x86_64)
EB> Thanks in advance
EB>

0

Please sign in to leave a comment.