unit testing not working when using code coverage

Hello,

I finally got unit testing to work inside of phpstorm and I was very happy that it worked. But now I run into a new problem. When I use code coverage (after installing the required components like xdebug) I get no results, just exit code 255. I cannot find what is causing these problems. All documentation I found on Unit testing and code coverage in phpstorm just tell you to run with code coverage and voila, instant results.

I'm using a local wamp installation to do my unit testing as I am not able to make it work with our development server, no matter what run configuration I try.

Can somebody point me in the right direction for solving this problem?

Thank you in advance for your help.

Bas

1 comment
Comment actions Permalink

Hi there,

You can start with describing your setup in details, providing output of phpinfo() etc.

There is NO WAY to tell what's wrong with your setup purelly from your description as it contains no usefull information unfortunately.

But in any case (before doing the above) -- does phpunit generates code coverage when executing it from command line (assuming that you have configured it to do that)?

0

Please sign in to leave a comment.