[solved] PHPStorm 7.1.2 - Emmet stopped working after update

Hi everyone,

i recently updated PhpStorm from 7.0 to 7.1.2. Since then, Autocomplete in CSS / SCSS files is completely different than before.

I used to type d:n and expand it with Tab to display: none; - now i only get suggestions for "display", which means i have to type more. Not sure if this is caused by Emmet or Autocomplete itself.

I reimported my previous settings and also tried deleting my User/.WebIde70 folder and reimporting again. I'm pretty sure that the same plugins are enabled / disabled and i checked that Emmet is activated like a dozen times.

Any hints would be appreciated.


Cheers,
Michael

2 comments
Comment actions Permalink

Hello!

please make sure that Settings/Emmet/'Enable CSS Emmet' and 'Enable fuzzy search among CSS abbreviations' options are enabled, and CSS:Emmet live templates are turned on in Settings/Live templates. If enabling these options doesn't help, please provide a screencast that shows up the issue

0
Comment actions Permalink

Aha! The live templates were not selected for some reason. Everything works as expected now. Thanks, Elena!

0

Please sign in to leave a comment.