Can't install Javascript debugger.

Hello everyone, I'm using PhpStorm 7.1.2.

So i follow this guide to install the debugger(I dont really need the live edit i only wanted the tutorial part about the debugger): http://confluence.jetbrains.com/display/PhpStorm/Live+Edit+in+PhpStorm

My phpstorm settings:

But i can't start the debugger, I keep getting(Built-in HTTP server on custom port 63342 disabled: Cannot start built-in HTTP server on custom port 63342. Please ensure that port is free (or check your firewall settings) and restart PhpStorm) What i try to do is:

  • I check port setting on the Chrome IDE extention and the ip is 127.0.0.1 and port is 63342(http://i.imgur.com/8nVK8du.png)
  • This is my debugger settings(http://i.imgur.com/0VmLtwN.png)
  • I open 63342 port (UDP AND TCP) on my router for the internal and external ip
  • I also open 63342 in my firewall (UDP AND TCP) at Inbound and Outbound Rules
  • Also PhpStorm settings for Javascript debugging, Port is 63342 with Can accept external connection option is checked(http://i.imgur.com/QWXHkw6.png)


Edit: I follow this steps from this link http://confluence.jetbrains.com/display/WI/LiveEdit:

  • Open chrome://extensions/
  • Check "Developer mode" checkbox.
  • Scroll down to JetBrains IDE Support section, click Inspect views: _generated_background_page.html.
  • Click on the "Console" button.

  • And this is the result(http://i.imgur.com/qpc3TOP.png)

    About my localhost, I have apache server running on port 80, I dont know if there is connection between my apache server and my problem, But just to be sure.

    If anyone know about something i forgot to do because i can't start the debugger please name it, Thank you all and have a nice day.

    1 comment
    Comment actions Permalink

    please can you attach your idea.log?


    0

    Please sign in to leave a comment.