Webstorm: closure linter does not respect --disable flag

I've configure the closure linter for javascript in Webstorm and set the options in a separate file with the following flags/opts:

--strict
--jsdoc
--summary
--beep
--check_html
--nomultiprocess
--debug_indentation
--time
--disable 1


It works well for all options except the 'disable' flag. When I configure this flag, I get an error notification at the top inside file editor with the message: "Closure Linter: Unknown command line flag 'disable 1'". I've tried this flag from the command line and it works fine, but for some reason the IDE doesn't like it.

More details on the gjslint disable flag here: https://code.google.com/p/closure-linter/issues/detail?id=16

4 comments
Comment actions Permalink

Hello!

Logged as http://youtrack.jetbrains.com/issue/WEB-10879, please vote for it to be notified on any progress

0
Comment actions Permalink
As a workaround, split up line
--disable 1
into two lines:
--disable
1
0
Comment actions Permalink

The workaround seems to do the job. Thanks!

0
Comment actions Permalink
disable=1 works even better.


Thanks!

0

Please sign in to leave a comment.