PHPStorm 7.1 + Xdebug on Ubuntu 13.04

Hi guys, I'm having a nightmare getting XDebug working properly with PHPStorm 7.1 (I've decided to try it out and see if it's worth the switch from Netbeans).

I am using Ubuntu 13.04, Apache 2.*, PHP 5.4.9. Xdebug is installed according to phpinfo.

I have a the following setup:

- A vhost directs every request through a dispatcher.php file (front controller pattern)
- The files are located in ~/Dev/work/trunk
- The dispatcher is in ~/Dev/work/trunk/some/directories/here/dispatcher.php
- I can access this application by going to http://trunk.local

I am not using any remote server (apart from SVN for commits, which seems to be working fine in PHPstorm). I simply want to get PHPStorm using xdebug in like netbeans could.

Settings

In "settings", PHP language level is 5.4, and the interpreter is set to PHP home: "/usr/bin" and the Debugger is "Xdebug 2.2.1". So it seems to have found it okay.

In Servers, I have put host: 127.0.0.1 and port 80. The Debugger is "Xdebug". Here's an issue: Clicking "Validate remote environment" and choosing a deployment server Localhost (which uses the "In Place" option with the server root as http://trunk.local), then clicking validate, says "Failed to execute validation script: 'Could not read from http://trunk.local/_intellij_phpdebug_validator.php" because it is not a file.'.

The ports both in Xdebug settings in my php.ini and in the PHP > Debug settings in PHPstorm are "9000".

I have clicked "Start listen for PHP Debug connections" at the top, and I have the Google Chrome extension from JB and also a php xdebug helper installed.

The Issue

Clicking "Debug [name]" at the top just shows "Waiting for incoming connection with ide key 'PHPSTORM'". That's it! Nothing in the browser.

Can someone help me sort this out?

2 comments
Comment actions Permalink

Edit, I fixed this, but I have no idea how. Way to go PHPstorm!

0
Comment actions Permalink

Hi there,

Addition: I changed the helper ide key from PHPSTORM to "PHPSTORM" (note the quotes).

Wrong move.

Here's an issue: Clicking "Validate remote environment" and  choosing a deployment server Localhost (which uses the "In Place" option  with the server root as http://trunk.local), then clicking validate, says "Failed to execute validation script: 'Could not read from http://trunk.local/_intellij_phpdebug_validator.php" because it is not a file.'.

Screenshots please, that would show your config.

1) Settings | Deployment -- I need to see paths

2) Settings | PHP | Servers

...and the Debugger is "Xdebug 2.2.1". So it seems to have found it okay.

You linux may use different php.ini for CLI and apache. So it may appear as installed for CLI but may not for Apache. Double check that by checking phpinfo() output via browser.

have a the following setup:

1) What is your project root?
2) What is your website root (i.e. is it the same as project root .. or it is a subfolder, e.g. "PROJECT/httpdocs") ?
3) Do you have any symbolic links involved? xdebug works with resolved/final file paths ONLY while IDE works with them as is.

Generally speaking:
1) Delete any records in "Settings | PHP | Servers"
2) Follow http://confluence.jetbrains.com/display/PhpStorm/Zero-configuration+Web+Application+Debugging+with+Xdebug+and+PhpStorm -- use that "phone handle" icon + your browser extension for xdebug (IDE key does not really matter, at all -- as long as it's not empty). The wizard should popup window which will help you to setup your "PHP | Servers".

0

Please sign in to leave a comment.