10 comments
Comment actions Permalink

No, there is no way to change it


-1
Comment actions Permalink

Please, at least, change the default to display in ISO 8601 format, i.e. YYYY-MM-DD  HH:MM.  HH being in 24 hours format.

7
Comment actions Permalink

Hans, what OS do you use?
Generally, the format in PhpStorm depends on what format you have set in your system.

0
Comment actions Permalink

I am running Linux Ubuntu 16.04 and you put me on the right track.  I had LC_TIME=fr_FR.utf8 configured.  Switched to LC_TIME=fr_CA.utf8 and the problem is mostly fixed.  I say mostly because fr_CA.utf8 states that the format date format is YYYY-MM_DD, as the command 'date' shows below, but IDEA still shows the year with two digits instead of four.

# LC_TIME=fr_CA.utf8
# date +%x
2017-06-13

1
Comment actions Permalink

The way I got ISO 8601 working on IDEA 2017.1 with Linux Mint 17.3 was by editing the file ~/.IntelliJIdea2017.1/idea64.vmoptions, adding this property to the bottom:

-Duser.language=sv

Though it seems to be an ugly hack, as the IDE still being in English relies on JetBrains never adding a Swedish l10n. I may try fiddling with my system locale as Hans suggested.

2
Comment actions Permalink

I can confirm that "LC_TIME=en_DK.utf-8 phpstorm" Does not work to get the ISO-8601.

Skoskav's hack with the "-Duser.language=sv" worked on my phpsorm in the file: "/opt/phpstorm/bin/phpstorm64.vmoptions" 

I get an additional issue with the font rendering, the date is cut off at the anotations, when they are marked as last change (fat).

I would vote to having a date preference clean in phpstorm settings !!

0
Comment actions Permalink

Adding this to my environment works for me (on Fedora 25):

    export LC_TIME=sv_SE

This gives me ISO-8601 dates (eg 2017-08-23) in Git Log view, and Git Annotate.

I haven't found out what other applications that environment variable affects yet. If it becomes a problem, I'll have to add it to the environment just for IntelliJ (and JetBrains Toolbox).

Ref: https://upsource.jetbrains.com/idea-ce/file/idea-ce-aa605118de5a6bd119f8d7bb9dda471d7ed60111/platform/util/src/com/intellij/util/text/DateFormatUtil.java?nav=12632:12632:focused

Edit: LC_TIME=sv_SE works better than LC_TIME=sv (which produces this warning on stdout: Gtk-WARNING **: Locale not supported by C library. Using the fallback 'C' locale.)

0
Comment actions Permalink

My system time locale is set to `LC_TIME=en_SE.UTF-8` which works everywhere else, but IDEA still shows the retarded US date format. `sv_SE.UTF-8` gives me the fallback warning but shows proper dates, which is weird because `LC_TIME=C` still shows US dates. I can't use sv_SE globally because its long date format uses swedish words, all I want is ISO8601 for the short format. 

 

Setting 

-Duser.language=sv

in .vmoptions also didn't work

0
Comment actions Permalink

That's an ugly solution, but at least it's a chance - please follow Alexander's advice here:

https://youtrack.jetbrains.com/issue/IDEABKL-6449#focus=streamItem-27-2697288-0-0

0

Please sign in to leave a comment.