Web module with IDEA 4.0.3

Recently I tried to config my application as a Web module with Tomcat 4 or 5. However, when I tried to run the Web module, I got the following command line:

C:/j2sdk1.4.2_04\bin\java -Dcatalina.base=C:\IDEA403\system\tomcat_SampleWebModule_8a4d7450 -Djava.endorsed.dirs=C:\TEMP\Tomcat5\common\endorsed -Dcatalina.home=C:\TEMP\Tomcat5 -Djava.io.tmpdir=C:\TEMP\Tomcat5\temp -Dfile.encoding=windows-1252 -classpath C:\j2sdk1.4.2_04\lib\tools.jar;C:\TEMP\Tomcat5\bin\bootstrap.jar;C:\IDEA403\lib\idea_rt.jar -Didea.launcher.port=7532 -Didea.launcher.library=C:\IDEA403\bin\breakgen.dll com.intellij.rt.execution.application.AppMain org.apache.catalina.startup.Bootstrap start

I have no way of specifying the parameters: catalina.base and java.endorsed.dirs. This has caused trouble in my application.

Does anyone know whether there is anyway around this?

1 comment
Comment actions Permalink

Yes, you can edit your catalina.bat and .sh files in your Tomcat/bin directory and comment out those lines. IDEA simply passes additional parameters to those batch files/scripts when it launches Tomcat. The two parametes you mentioned are in those files by default.

0

Please sign in to leave a comment.