Can't shutdown Tomcat

I've just been playing around with IDEA 4.5 and I'm experiencing a problem where I can't shutdown the Tomcat instance (5.0.27) through IDEA.

When I run Tomcat through IDEA the Stop button is initially enabled. A few seconds into the startup, the message "Disconnected from server" is printed and the Stop button is disabled. At this point IDEA thinks Tomcat is stopped, but it is actually continuing to start. After startup it runs fine.

This problem only occurs when I setup a JNDI database pool in Tomcat for the context I am deploying. I have tried setting up the context in server.xml and in conf\Catalina\localhost\]]>.xml and I see the same problem with both. Removing the context setup leaves IDEA able to stop Tomcat, but I am unable to run my application as it needs the database pool.

The Tomcat integration works fine in debug mode. The problem only occurs when running the project.

This seems to be a similar problem to tracker id 35851:
http://www.intellij.net/tracker/idea/viewSCR?publicId=35851

Has anyone else seen this problem? Are there any workarounds (other than having to run the Tomcat shutdown script manually)?

1 comment

Please sign in to leave a comment.