IntelliJ 4.0.3: WebLogic VM parameters ignored.

When you specify VM parameters in your WebLogic configuration, they are not passed to the VM.

E.g. I enter a parameter as follows:

-Dcom.vignette.portal.installdir.path=C:\VAP71\Portal

but it is ignored, as are any others. This looks like a straightforward bug - can anyone else confirm this, comment or suggest a workaround ?

Thanks in advance.

5 comments
Comment actions Permalink

Hi,

What version of the Weblogic you are using?

Damien Argento wrote:

When you specify VM parameters in your WebLogic configuration, they are not passed to the VM.

E.g. I enter a parameter as follows:

-Dcom.vignette.portal.installdir.path=C:\VAP71\Portal

but it is ignored, as are any others. This looks like a straightforward bug - can anyone else confirm this, comment or suggest a workaround ?

Thanks in advance.



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

Hi Maxim

WebLogic 8.1 SP2. I have worked around it by setting the JAVA_OPTIONS environment variable.

Regards

David Shipp

0
Comment actions Permalink

Hi,

Have you changed your Weblogic startup script?
It should use externally set JAVA_OPTIONS variable like
set JAVA_OPTIONS=%JAVA_OPTIONS%;...
This happens by the default.

David Shipp wrote:

Hi Maxim

WebLogic 8.1 SP2. I have worked around it by setting the JAVA_OPTIONS environment variable.

Regards

David Shipp



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

Hi Maxim

My WebLogic startup script works fine outside of IntelliJ. But IntelliJ does not use the startup script. Instead it starts WebLogic using the configurations set up inside IntelliJ on the WebLogic Server Integration dialog. This is where you can specify VM parameters - but IntelliJ ignores them !

David

0
Comment actions Permalink

Sorry for misleading you, the IDEA 4.5 works direcly with the server
scripts and my advice was about this version.

David Shipp wrote:

Hi Maxim

My WebLogic startup script works fine outside of IntelliJ. But IntelliJ does not use the startup script. Instead it starts WebLogic using the configurations set up inside IntelliJ on the WebLogic Server Integration dialog. This is where you can specify VM parameters - but IntelliJ ignores them !

David



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Please sign in to leave a comment.