New File not associated with PHP

I am confused. When I create a new PHP file using the IDE 'New' option and selecting PHP, I get a file that has an extension .php but unlike the other files in the project it doesn't have the PHP icon associated with it. It seems that it is not recognized as a PHP file. How do I register it?



Attachment(s):
newfile.jpg
3 comments
Comment actions Permalink

Hi there,

Settings | File Types | Text files

Find wrong/unwanted pattern there and remove it (I believe it will be "expand.php" or similar to that).

1
Comment actions Permalink

I don't see 'File Types' in the settings. I have attached a screen shot of what I do see.



Attachment(s):
filetype.jpg
0
Comment actions Permalink
I don't see 'File Types' in the settings.

Well ... I do see it there on your screenshot.

Try typing "file types" in search box (top left corner) if you are unable to find it -- this will narrow settings a lot.

P.S.
Do not forget that Settings screen shows both Current Project settings (top part fo the list) as well as IDE settings (bottom part of the list) at the same time.

0

Please sign in to leave a comment.