Karma isn't finding unit tests in *Spec.js

For some reason when I run this Karma.conf the test runner runs without errors but it doesn't actually run any of my tests in the *Spec.js files. Any ideas?

// Karma configuration
// Generated on Fri Jan 03 2014 12:02:32 GMT+0000 (GMT)

module.exports = function (config) {
    config.set({

        // base path, that will be used to resolve files and exclude
        basePath: '',


        // frameworks to use
        frameworks: ['jasmine'],


        // list of files / patterns to load in the browser
        files: [
            '../../root/angular/angular.js',
            //'angular/angular-mocks.js',
            '../../root/angular/**/*.js',
           // 't/js/angularTest/process/filtersSpec.js',
            'angularTest/**/*Spec.js'
        ],


        // list of files to exclude
        exclude: [

        ],


        // test results reporter to use
        // possible values: 'dots', 'progress', 'junit', 'growl', 'coverage'
        reporters: ['progress',"coverage"],

        preprocessors:{
            '**/*.js':'coverage'
        },

        // web server port
        port: 9876,


        // enable / disable colors in the output (reporters and logs)
        colors: true,


        // level of logging
        // possible values: config.LOG_DISABLE || config.LOG_ERROR || config.LOG_WARN || config.LOG_INFO || config.LOG_DEBUG
        logLevel: config.LOG_INFO,


        // enable / disable watching file and executing tests whenever any file changes
        autoWatch: false,


        // Start these browsers, currently available:
        // - Chrome
        // - ChromeCanary
        // - Firefox
        // - Opera (has to be installed with `npm install karma-opera-launcher`)
        // - Safari (only Mac; has to be installed with `npm install karma-safari-launcher`)
        // - PhantomJS
        // - IE (only Windows; has to be installed with `npm install karma-ie-launcher`)
        browsers: ['Chrome'],


        // If browser does not capture in given timeout [ms], kill it
        captureTimeout: 60000,


        // Continuous Integration mode
        // if true, it capture browsers, run tests and exit
        singleRun: false
    });
};

this is my output from Karma if it helps:

/usr/bin/node /home/me/Desktop/WebStorm-131.515/plugins/js-karma/js_reporter/karma-intellij/lib/intellijRunner.js --karmaPackageDir=/usr/lib/node_modules/karma --serverPort=9876 --urlRoot=/
Testing started at 10:04 ...
Empty test suite.

Process finished with exit code 0
2 comments
Comment actions Permalink

Hello!

do you have angular-scenario.js file loaded? According to http://stackoverflow.com/questions/18102390/angularjs-karma-e2e-executed-0-of-0-error and
https://github.com/angular/angular-phonecat/issues/71, it may cause problems like yours

If it's not your case, please provide the following information:
1) Node.js version
2) Karma version
3) 'Karma server' tab output
4) Standard output of the following command (run outside of webstrom):
 

/usr/bin/node /home/me/Desktop/WebStorm-131.515/plugins/js-karma/js_reporter/karma-intellij/lib/intellijRunner.js 
--karmaPackageDir=/usr/lib/node_modules/karma --serverPort=9876 --urlRoot=/


 .

0
Comment actions Permalink

thanks, one of my angular imports threw it, commenting it out fix the issue

:)
0

Please sign in to leave a comment.