How do I stop PHPStorm (7.0 131.374) from adding a BOM

In most normal editors I can tell the editor how to deal with the BOM - specifically I want it to stop adding a BOM to files that do not have a BOM, in fact I want it to always remove a BOM if it finds one in a file it edits.  I have spent two hours messting about tracking down an obscure bug because of this dumb behaviour.

I have been evaluating PHPStorm and I like it alot but this for me is an instant show-stopper.

Is there an option to change the editor's behaviour?

Gerry

3 comments
Comment actions Permalink

Forgot to mention, I am running on OSX 10.9

0
Comment actions Permalink

Hello!

1. PhpStorm normally creates files in UTF-8 encoding without BOM
2. If such file was created elsewhere with BOM,  you can always use "File | Remove BOM" to remove it

0
Comment actions Permalink

HI, yes I found that option and that seems to have done the trick. I did remove the BOM using an external tool but that did not work, but perhaps PHPStorm already had it open or cached or something. Thanks for the response - I am up and running again.

Gerry

0

Please sign in to leave a comment.