No access to user folders when phpStorm 7.0 under Windows 7 64bit

Hi,
I have not been able to access any of my user folders (such as my documents, desktop, dropbox, google drive) . When looking at the c:\Users folder only Public and UpatusUser are shown but not my user. Tried running phpStorm as administrator but got the same results. Installed version of java is jre7 (32 bits).
Is there anything I need to check in order to get access to these folders?

Thank you in advance.

2 comments
Comment actions Permalink

Hi there,

PhpStorm for Windows comes with it's own JRE 1.7 and uses it instead of Java installed on your system (unless configured otherwise).

PhpStorm keeps its' settings and indexes/caches/etc in C:\Users\USERNAME\.WebIde70 folder -- if IDE works fine (otherwise than the issue described here) then it is able to access and modify those files (unless it is stores them in another location).

Please check idea.log (Help | Show Log in Explorer) for possible hints/details.

Right now it sounds like either file permissions issue of some kind (but no real idea what exactly it could be .. as it sounds quite weird) .. or IDE affected by Antivirus (or rather Internet Security) which could restrict app (for some reason) from accessing certain folders (i.e. Kaspersky Internet Security).

P.S.
You could use something like Process Monitor or alike to see what is going on -- maybe it will give you some hints.

0
Comment actions Permalink

Thank you for your input. It turned out that my c:\users\Richard directory was a hidden system file. Running an attrib -s -h Richard fixed the problem. Hope this is informational for someone else.

0

Please sign in to leave a comment.