Getting connection refused on built in web server

I just enabled the checkbox "Debugger/JavaScript/Can accept external connections" and still, I can only connect to port 63342 from localhost.  External connection attemts get the "Connection refiused" transport error.  Any ideas?

Gerry

6 comments

Hello!

not sure what's wrong, but here are instruction for connecting from different host:
- on a remote host, make sure to install JetBrains IDE Support extension into Chrome
- in extension options  (chrome-extension://hmhgeddbohgjknpmjagkdomcpobmllji/options.html),  specify the IP and port of the target machine
- on a target computer, start WebStorm, make sure that the port  specified in Settings/JavaScript/Debugger is the same as above and 'Can  accept external connections' is on. Open your project and run your  application. This should do the thing

0

I am not sure I made the problem clear.  Let me try again. When I run PHPStorm and work on an HTML page in a project (my project is called "test"), I can float the mouse arount the top right of the editor window and get a small pop-up which alows me to launch the page I am editing into a browser for test and preview. When I do this, it launches the following URL:

http://localhost:63342/test/#home

and I can browse the site I am working on - looking at the URL this the server that is built into PHPStorm editor. So this all works absolutely fine.  

Now here is the problem. I want to test that same site on an iPad which is connected to the same network as my computer.  My computers IP address is 192.168.123.237 so from the iPad I browse to the following URL:

http://192.168.123.237:63342/test/#home

and I would expect to see the test site, but instead I get a "Connection Refused" message which means that the web server built into PHPStorm is explicitly refusing the connection from the external host, and this is despite me turning on the option to allow external connections.

Does this make sense?

Gerry

0

I see:) Please try changing the default port to something else. 63342 is default port number for all IDE services
See also http://youtrack.jetbrains.com/issue/IDEA-111388

0

Hi,

Thanks that worked - very odd that the actial port number should matter. In any case I found tghe internal HTTP server to be really unstable so I have since configured Apache and thats working much better. Its really confusing trying to configure PHPStorm, there are about 1000x more options than would appear necassery IMHO. Anyway, I seem to be uop and running now...

Gerry

0

@Elena

I have to ask why would you use a default port that is not accessible to other computers on the local network. Glad I came across this article as I have spent time on this same problem, very frustrating.

0

external connections to this port are blocked for security reasons, to avoid possible vulnerabilities

0

Please sign in to leave a comment.