PHPStorm processor usage when editing javascript files

I am using PHPStorm mainly to edit php and javascript files. When I edit php files, no mater how big, no matter how complicated, all is fine.

When I edit javascript files which contain objects, not very big files, not libraries, just my js files, PHPStorm UI often becomes unresponsive for two-three seconds (many times during edits).

I noticed that it keeps the processor busy at ~50%.

I also noticed that when this happens the processor temperature is significantly higher (almost 50% higher). You could say "get a better processor" - but I use Sketchup, Photoshop, Video editing software and generally these programs don't increase the temperature almost at all (with exception to rendering a movie, which takes 100% tics). This makes me think that the PHP Storm UI is not optimised for something related to javascript, or something useless is keeping the processor busy.

P.S. This is about version 7, I think there was no such problem with the previous version.

17 comments

Hello!

Please can you provide CPU snapshots/thread dumps taken at the moments when the IDE is unresponsive? See http://devnet.jetbrains.com/docs/DOC-192 and http://devnet.jetbrains.com/docs/DOC-260 for more information on reporting performance issues

1





Same problem. MacOS 10.12 (core i5, 12 Gb RAM)
storm 2017.1

1

Please provide CPU snapshots per instructions above

1

Please try 2017.3 EAP (https://confluence.jetbrains.com/display/PhpStorm/PhpStorm+Early+Access+Program) - it includes some improvements. If the problem persists, please try taking longer snapshot

0

problem not sloved :-(
computer collapsed by storm... its hard to make CPU snapshot

0

without snapshots we have no chance to see what's going on:(

0

i launch  2017.2.4 version. After indexing will try to make snapshot

0

please provide a memory snapshot + idea.log

0

http://dropmefiles.com/zcZam - memory snapshot PHPstorm 2017.2.4

http://dropmefiles.com/xDmaM - cpu snapshot PHPstorm 2017.2.4

where is  "idea.log"?

> without snapshots we have no chance to see what's going on:(

You can launch storm on your macOS. i hope your QA have it.

 

Same situation in .php file too if php file contains many JS

 
0

Please try 2017.3 EAP with `-Djs.max.files.to.process=2` added to .vmoptions file (Help | Edit custom VM options) - does it work?

0

Do not work :-(

problem in validation. My friends disable validation, and phpstorm stopped consuming processor


0

Any news?

The problem still exists

0

Please sign in to leave a comment.