.tld files present all tags in red in pallada

Hi,

When I display a .tld file in Pallada, all the tags show in red, and
with a tooltip of "Cannot resolve symbol name".
Only the first tag ( ]]> ) is recognized.
I added the URL in the resources, but it doesn't change anything.
What is even stranger is that when I try to use auto-completion (by
pressing '<'), it shows all the possible tags, so it means it does
recognizes them.

Is this a known bug or a problem with my conf?

Any idea?

Thanks,

BoD

13 comments
Comment actions Permalink

Check your web module settings, specifically the "Web Resource Directory".

Norris Shelton
Sun Certified Java Programmer




BoD wrote:

Hi,

>

When I display a .tld file in Pallada, all the tags show in red, and
with a tooltip of "Cannot resolve symbol name".
Only the first tag ( <taglib> ) is recognized.
I added the URL in the resources, but it doesn't change anything.
What is even stranger is that when I try to use auto-completion (by
pressing '<'), it shows all the possible tags, so it means it does
recognizes them.

>

Is this a known bug or a problem with my conf?

>

Any idea?

>

Thanks,

>

BoD

0
Comment actions Permalink

Norris Shelton wrote:

Check your web module settings, specifically the "Web Resource Directory".

More specifically, i couldn't get this to work unless i put my web directory as content root of the web module.

/Kreiger

0
Comment actions Permalink

I'm sorry, but I don't understand.
Currently here is my conf:

My webapp is in d:\webapps\fooproj

The settings in the web module settins tabs are:
.Deployment descriptor location: d:\webapps\fooproj\WEB-INF\web.xml
.Web Resource Directory: d:\webapps\fooproj | Relative path in
deployment directory : /

What do I have to change?

BoD




Christoffer "Kreiger" Hammarström wrote:

Norris Shelton wrote:

>> Check your web module settings, specifically the "Web Resource
>> Directory".
>>

More specifically, i couldn't get this to work unless i put my web
directory as content root of the web module.

/Kreiger


0
Comment actions Permalink

Did you add the libraries for your tag libs to your module?

0
Comment actions Permalink

BoD wrote:

I'm sorry, but I don't understand.
Currently here is my conf:

My webapp is in d:\webapps\fooproj

The settings in the web module settins tabs are:
.Deployment descriptor location: d:\webapps\fooproj\WEB-INF\web.xml
.Web Resource Directory: d:\webapps\fooproj | Relative path in
deployment directory : /

What do I have to change?

BoD


"Settings" -> "Paths" -> Your web module -> "Paths" (Leftmost tab) -> "Add Content Root" -> "d:\webapps\fooproj".
You probably need to remove your current content root first.

This is using Pallada build #2013.

/Kreiger

0
Comment actions Permalink

Yup :)

BoD


Robert S. Sfeir wrote:

Did you add the libraries for your tag libs to your module?

0
Comment actions Permalink

Thank you for your help, but unfortunately it still does the same thing.

Maybe it is not clear what it exactly does so I made a screenshot here :
http://www.jraf.org/blorp_files/tmp/tldproblem.jpg

As you can see, the and ]]> elements are recognized. Plus the
popup displays a list of all the other elements.

Strange, isn't it?

BoD


Christoffer "Kreiger" Hammarström wrote:

BoD wrote:

>> I'm sorry, but I don't understand.
>> Currently here is my conf:
>>
>> My webapp is in d:\webapps\fooproj
>>
>> The settings in the web module settins tabs are:
>> .Deployment descriptor location: d:\webapps\fooproj\WEB-INF\web.xml
>> .Web Resource Directory: d:\webapps\fooproj | Relative path in
>> deployment directory : /
>>
>> What do I have to change?
>>
>> BoD
>>


"Settings" -> "Paths" -> Your web module -> "Paths" (Leftmost tab) ->
"Add Content Root" -> "d:\webapps\fooproj".
You probably need to remove your current content root first.

This is using Pallada build #2013.

/Kreiger

0
Comment actions Permalink

I've seen this too. It seems like IDEA is trying to use the JSP1.2 dtd
instead of the 1.1 that you've specified. The only workaround I've found is
to switch to 1.2.

"BoD" <BoD@JRAF.org> wrote in message news:c6o5t1$4po$2@is.intellij.net...

Thank you for your help, but unfortunately it still does the same thing.

>

Maybe it is not clear what it exactly does so I made a screenshot here :
http://www.jraf.org/blorp_files/tmp/tldproblem.jpg

>

As you can see, the <taglib> and <tag> elements are recognized. Plus the
popup displays a list of all the other elements.

>

Strange, isn't it?

>

BoD

>
>

Christoffer "Kreiger" Hammarström wrote:

>

BoD wrote:

>
>> I'm sorry, but I don't understand.
>> Currently here is my conf:
>>
>> My webapp is in d:\webapps\fooproj
>>
>> The settings in the web module settins tabs are:
>> .Deployment descriptor location: d:\webapps\fooproj\WEB-INF\web.xml
>> .Web Resource Directory: d:\webapps\fooproj | Relative path in
>> deployment directory : /
>>
>> What do I have to change?
>>
>> BoD
>>
>

"Settings" -> "Paths" -> Your web module -> "Paths" (Leftmost tab) ->
"Add Content Root" -> "d:\webapps\fooproj".
You probably need to remove your current content root first.

>

This is using Pallada build #2013.

>

/Kreiger



0
Comment actions Permalink

Ah, ha. What would be the point of using JSP 1.1? What web container
doesn't support 1.2?

However, you should report this as a bug because IntelliJ should still
support 1.1.

Norris Shelton
Sun Certified Java Programmer




Brad wrote:

>I've seen this too. It seems like IDEA is trying to use the JSP1.2 dtd
>instead of the 1.1 that you've specified. The only workaround I've found is
>to switch to 1.2.
>
>"BoD" <BoD@JRAF.org> wrote in message news:c6o5t1$4po$2@is.intellij.net...

>
>>Thank you for your help, but unfortunately it still does the same thing.
>>
>>Maybe it is not clear what it exactly does so I made a screenshot here :
>>http://www.jraf.org/blorp_files/tmp/tldproblem.jpg
>>
>>As you can see, the and elements are recognized. Plus the >>popup displays a list of all the other elements. >> >>Strange, isn't it? >> >>BoD >> >> >>Christoffer "Kreiger" Hammarström wrote: >> >> >> >>>BoD wrote: >>> >>> >>> >>>>I'm sorry, but I don't understand. >>>>Currently here is my conf: >>>> >>>>My webapp is in d:\webapps\fooproj >>>> >>>>The settings in the web module settins tabs are: >>>>.Deployment descriptor location: d:\webapps\fooproj\WEB-INF\web.xml >>>>.Web Resource Directory: d:\webapps\fooproj | Relative path in >>>>deployment directory : / >>>> >>>>What do I have to change? >>>> >>>>BoD >>>> >>>> >>>> >>>"Settings" -> "Paths" -> Your web module -> "Paths" (Leftmost tab) -> >>>"Add Content Root" -> "d:\webapps\fooproj". >>>You probably need to remove your current content root first. >>> >>>This is using Pallada build #2013. >>> >>> /Kreiger >>> >>> > >]]>

>

0
Comment actions Permalink

The version of iPlanet we use only supports J2EE1.2 which is JSP1.1. At least that is what I have been told by our administrator.
"Norris Shelton" wrote in message news:408FB0BC.90904@yahoo.com... Ah, ha. What would be the point of using JSP 1.1? What web container doesn't support 1.2? However, you should report this as a bug because IntelliJ should still support 1.1. Norris Shelton Sun Certified Java Programmer Brad wrote: I've seen this too. It seems like IDEA is trying to use the JSP1.2 dtd instead of the 1.1 that you've specified. The only workaround I've found is to switch to 1.2. "BoD" wrote in message news:c6o5t1$4po$2@is.intellij.net... Thank you for your help, but unfortunately it still does the same thing. Maybe it is not clear what it exactly does so I made a screenshot here : http://www.jraf.org/blorp_files/tmp/tldproblem.jpg As you can see, the and elements are recognized. Plus the popup displays a list of all the other elements. Strange, isn't it? BoD Christoffer "Kreiger" Hammarström wrote: BoD wrote: I'm sorry, but I don't understand. Currently here is my conf: My webapp is in d:\webapps\fooproj The settings in the web module settins tabs are: .Deployment descriptor location: d:\webapps\fooproj\WEB-INF\web.xml .Web Resource Directory: d:\webapps\fooproj | Relative path in deployment directory : / What do I have to change? BoD "Settings" -> "Paths" -> Your web module -> "Paths" (Leftmost tab) -> "Add Content Root" ->]]> "d:\webapps\fooproj".
You probably need to remove your current content root first.

This is using Pallada build #2013.

/Kreiger


0
Comment actions Permalink

The project I'm working on uses this tld file, and I'm just not supposed
to touch it.

BoD

Norris Shelton wrote:

Ah, ha. What would be the point of using JSP 1.1? What web container
doesn't support 1.2?

However, you should report this as a bug because IntelliJ should still
support 1.1.

Norris Shelton
Sun Certified Java Programmer

0
Comment actions Permalink

Ouch. The mere fact that you are using iPlanet makes me feel sorry for
you. You must be a prisoner to your IT department. Don't worry, one
day you will get to upgrade to 1.2, but by then, we will be onto JSP
2.1. :(

Norris Shelton
Sun Certified Java Programmer




Brad wrote:

The version of iPlanet we use only supports J2EE1.2 which is JSP1.1.
At least that is what I have been told by our administrator.

>

"Norris Shelton" <norrisshelton@yahoo.com
<mailto:norrisshelton@yahoo.com>> wrote in message
news:408FB0BC.90904@yahoo.com...
Ah, ha. What would be the point of using JSP 1.1? What web
container doesn't support 1.2?

>

However, you should report this as a bug because IntelliJ should
still support 1.1.

>
>Norris Shelton
>Sun Certified Java Programmer
>

>
>
>

Brad wrote:

>
>>I've seen this too. It seems like IDEA is trying to use the JSP1.2 dtd
>>instead of the 1.1 that you've specified. The only workaround I've found is
>>to switch to 1.2.
>>
>>"BoD" wrote in message news:c6o5t1$4po$2@is.intellij.net... >> >> >>>Thank you for your help, but unfortunately it still does the same thing. >>> >>>Maybe it is not clear what it exactly does so I made a screenshot here : >>>http://www.jraf.org/blorp_files/tmp/tldproblem.jpg >>> >>>As you can see, the and elements are recognized. Plus the >>>popup displays a list of all the other elements. >>> >>>Strange, isn't it? >>> >>>BoD >>> >>> >>>Christoffer "Kreiger" Hammarström wrote: >>> >>> >>> >>>>BoD wrote: >>>> >>>> >>>> >>>>>I'm sorry, but I don't understand. >>>>>Currently here is my conf: >>>>> >>>>>My webapp is in d:\webapps\fooproj >>>>> >>>>>The settings in the web module settins tabs are: >>>>>.Deployment descriptor location: d:\webapps\fooproj\WEB-INF\web.xml >>>>>.Web Resource Directory: d:\webapps\fooproj | Relative path in >>>>>deployment directory : / >>>>> >>>>>What do I have to change? >>>>> >>>>>BoD >>>>> >>>>> >>>>> >>>>"Settings" -> "Paths" -> Your web module -> "Paths" (Leftmost tab) -> >>>>"Add Content Root" -> "d:\webapps\fooproj". >>>>You probably need to remove your current content root first. >>>> >>>>This is using Pallada build #2013. >>>> >>>> /Kreiger >>>> >>>> >> >> >> >>]]>

0
Comment actions Permalink

Ah, ha. What would be the point of using JSP 1.1?
What web container doesn't support 1.2?


For example, latest stable version (1.1) of Struts framework comes with TLD's for JSP 1.1 for its custom tags.

0

Please sign in to leave a comment.