Configure indention of copyright comment

Hi community,

maybe someone has an idea for this problem.

I'm developing for TYPO3 sometimes and the head of the PHP files looks like that (shortended comments for readability):

<?php
namespace TYPO3\CMS\Core\Database;

/***************************************************************
*  Copyright notice
*
*  [...]
*
*  This copyright notice MUST APPEAR in all copies of the script!
***************************************************************/

/**
* Contains the class "DatabaseConnection" containing functions for building SQL queries
* [...]
*
* @author Kasper Skårhøj <kasperYYYY@typo3.com>
*/
class DatabaseConnection {


Now my problem is: when I reformat files the copyright notice will always be indented, so the header looks like that afterwards:

namespace TYPO3\CMS\Core\Database;

    /***************************************************************
     *  Copyright notice
     *
     *  [...]  
     *
     *  This copyright notice MUST APPEAR in all copies of the script!
     ***************************************************************/

/**
* Contains the class "DatabaseConnection" containing functions for building SQL queries
* [...]
*
* @author Kasper Skårhøj <kasperYYYY@typo3.com>
*/
class DatabaseConnection {


Is there a setting I can use to prevent the indent of the copyright?

Cheers,
Alex

Please sign in to leave a comment.