'Insert pair quote' setting playing up.

I am almost certain that I am simply missing something, but alas I cannot figure it out.

I prefer to type things myself. Automatically inserted brackets and speech marks gets on my nerves because I end up with jumbled code as my muscle memory types out each character. In phpStorm 6 I had it set with all these features off, but I installed phpStorm 7 a few days ago and have been getting more and more frustrated with automatically inserted speech marks and cannot find a relevant setting other than "Settings > IDE Settings > Editor > Smart Keys > Insert pair quote", which is disabled and has no affect whatsoever.

For example... if I type:
<div id

Then add an =, I end up with the following with the cursor between the speech marks.
<div id=""

My muscle memory kicks in and I finish the line off with another speech mark, the id value, a closing speech mark and closing > which leaves me with:
<div id=""container">"

I've combed the various settings menus and cannot find a way to turn this off in phpStorm 7. As I said above, I'm certain that I'm missing something. Any help would be greatly appreciated as this is frustrating me beyond belief.

Cheers.

8 comments
Comment actions Permalink

I'm in the same boat.  I thought I might get used to it but it's killing me.  I recall seeing in another forum post that there isn't a way to turn it off yet.

0
Comment actions Permalink

Hm okay, that seems strange. I could swear I turned it off in 6.


0
Comment actions Permalink

Hi there,

The fix should be available in next minor version -- http://youtrack.jetbrains.com/issue/IDEA-113332

Not sure if it will end up in separate setting as described in that ticket or will it just improve editor logic (by eating double closing quote automatically)

0
Comment actions Permalink

I just took a look at that issue tracker and saw the "State: Fixed", which is brilliant news. I downloaded the latest EAP (131.441) and it hasn't fixed the issue.

Really not sure what I'm supposed to do to get this fix. Any thoughts?

0
Comment actions Permalink

You should have also seen the "Fixed in build: 132.844" field as well (which is a bit ahead compared to 131.441).

I cannot answer you at what PhpStorm version exactly it will have it. Hopefully they have / will back-port it to 131.xxx branch for 7.0.1 final release (at the moment it's just an EAP) ... or maybe (but this will be bad move from JB) we will have to wait a bit longer (in a month or so they expecting to switch to 133.xxx branch).

0
Comment actions Permalink

Oh yes, I'm clearly blind. Thank you for the information.

0
Comment actions Permalink

This is still an issue, and I'm on version 2020.1 !!!

If I enable...

Settings | Editor | General | Smart Keys | HTML/CSS | Add quotes for attribute value on typing '=' and attribute completion 

...then the closing quote does not get eaten when typed over.

So I disable it, which is way better than having to press the right arrow key when touch-typing reams of code.

Please, please, please, If you could fix this so the closing quote gets eaten then I'd be very happy and could enable it again.

0
Comment actions Permalink

>Please, please, please, If you could fix this so the closing quote gets eaten then I'd be very happy and could enable it again.

This is 7 years old thread. The issue described here is fixed and working fine for me in 2020.1.1 (just checked in plain HTML file when completing stuff in class attribute)

Your case should be different, e.g. specific technology/plugin involved, specific value entered etc. Please create brand new project and provide steps to reproduce it so the devs can look into this.

0

Please sign in to leave a comment.